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Thank you for your interest in ReliaSoft's Weibull++ and ALTA software tools. This quick start guide has
been designed to help you explore many of the software's key features by working through step-by-step
instructions for some practical application examples.

In order to demonstrate a variety of different applications for the tools available in Weibull++ and ALTA,
this guide asks you to imagine that you are a reliability engineer working for a large company with many
different product lines, then walks you through the steps you might take to answer a variety of questions
from different design groups and customers. Please note that the sample data sets provided are fictional
and intended for demonstration purposes. Furthermore, note that although this guide attempts to introduce
you to some of the most frequently used tools in the software, Weibull++ and ALTA support many other
reliability engineering methods and applications. Within the software, you can choose File > Help to
access a wide array of resources that will help you explore other software capabilities.

In addition to this introduction, the following chapters are presented in this guide. Note that the examples
in chapters 2 through 10 require Weibull++, chapters 11 and 14 can use either ALTA Standard or ALTA
PRO and chapters 12 and 13 require ALTA PRO.

Chapter 2: Life Data Analysis.............................................................................................................. page 3

Chapter 3: Degradation Analysis ....................................................................................................... page 31

Chapter 4: Design of Reliability Tests ............................................................................................... page 39
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Chapter 10: Event Log Data Analysis ............................................................................................... page 95
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Chapter 13: ALTA with Time-Dependent Stress Profiles ................................................................ page 123

Chapter 14: Accelerated Degradation Analysis ............................................................................... page 131

The quick start repository that is installed with the software (called
“Weibull_ALTA9_QuickStart_Rev2.rsgz9”) contains a sample project with completed analyses for all of
the examples. To access this file, choose File > Help, click Open Examples Folder, then browse for the
file in the Weibull or ALTA sub-folder.

All of the folios, plots and other analyses described in this guide are stored in the “Completed Examples -
- Weibull++ and ALTA Quick Start” project in the quick start database.When applicable, the instructions
in this guide will refer to a completed folio in the quick start project using a notation such as (“Bulb A -
Supplier Data” in the sample project). While reading any example in this guide, you have the choice to:

 Examine how it was completed in the sample project.

 Follow the instructions to complete the analyses “from scratch.”

Tip: To preserve the integrity of the shipped example files, the software creates a copy of the file each time you

access a repository  in the Examples folder. The copy has the same name as the original file and  is saved  in the
default documents folder for your computer (e.g., My Documents\ReliaSoft\Files). Use the copy to work on the
example projects and save your changes. Any changes you make in the copy will not affect the original file.
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 Copy data/analyses from the sample project to help you complete the analyses.

IMPORTANT: Note that  it may sometimes be necessary to modify the data  in the quick start repository to fit

updated instructions or new examples in the latest printing of this quick start guide. This printing of the guide was
designed for use with Weibull_ALTA9_QuickStart_Rev2.rsgz9 (where _RevX  indicates the database revision).  If
you try to use a different database revision, the sample projects may not exactly match the instructions printed
here. 1) If this guide is older than the latest database revision installed on your computer, you can choose File >
Help > Quick  Start Guide  to download  the  latest printing. 2)  If  this  guide  is newer  than  the  latest database
revision  installed on  your  computer,  you  can  choose  File > Help > Check  for Update  to download  the  latest
software service release.



In life data analysis, the goal is to model and understand the failure rate
behavior of a particular item, process or product. The models are built by
taking the observed “life” data, which can be obtained either from the field
or from in-house testing. Because time is a common measure of product life,
the life data points are often called times-to-failure data. There are two
general types of times-to-failure data: complete and censored. 

In this chapter, you will work with these types of data and use the Weibull++
standard folio to perform life data analysis.

2.1  Complete Data

You receive a request from a team of product engineers who are working on the design of a projector that
your company manufactures. You are asked to quantify the life characteristics of the projector bulb in
order to understand its reliability. You are given a data set for 10 bulbs that were all tested to failure by the

Life Data Analysis 2

 Standard folios

 Complete and 
censored data

 Confidence 
intervals

 QCP, plots and 
reports

Watch a video of this example at 
http://www.ReliaSoft.tv/weibull/startguide/weibull_qsg_2.html.
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bulb’s supplier. The test included shutdown and cooldown periods that were intended to simulate normal
use conditions. The failure times were 513, 649, 740, 814, 880, 944, 1009, 1078, 1161 and 1282 hours.
These failure times are called complete data.

Complete Data: The simplest case of life data is a data set where the failure time of each specimen
in the sample  is known. This type of data set  is referred to as complete data, and  is obtained by
recording the exact times when each unit failed. 

http://www.reliasoft.tv/weibull/startguide/weibull_qsg_2.html


2  Life Data Analysis

Objectives

 Estimate the average life of the bulb (i.e., MTTF or mean life).

 Estimate the B10 life of the bulbs (i.e., the time by which 10% of the bulbs will be failed, or the
time by which there is a 10% probability that a bulb will fail).

 Estimate the reliability of the bulbs after 200 hours of operation.

 Assuming 1,000 bulbs will be fielded, estimate how many would fail after 200 hours. 

 Estimate the warranty time for the bulb if you do not want failures during the warranty period to
exceed 2%. 

Solution

To answer the questions of interest to the design team, you will perform life data analysis on the complete
data set provided by the supplier.

First, you create a new Weibull++ standard folio (“Bulb A - Supplier Data” in the sample project) by
choosing Insert > Folios > Weibull++ Standard Folio.

MTTF and MTBF: The terms MTBF (mean time between failures) and MTTF (mean time to failure)
have often been  interchangeably used to describe the average time to failure. The truth  is, these
two metrics are not the same and should not be used interchangeably.

When  dealing with  non‐repairable  components  (as  in  the  case  of  life  data  analysis)  the metric
sought  is  the mean  time  to  failure or MTTF.  It  is only when dealing with  repairable components
(where the component may fail and be repaired multiple times during its operational life) that you
calculate the mean time between failures or MTBF. The only time that the MTTF and MTBF are the
same  is  when  the  failure  rate  is  constant  (i.e.,  when  the  underlying model  is  an  exponential
distribution). 
4 Weibull++/ALTA Quick Start Guide



2.1  Complete Data

When prompted to specify the data type, you select Times-to-failure data and clear all the other options.
You also use the Units drop-down list to indicate that the time values in the data sheet will be entered in
hours, as shown next.

Note: By clearing all the other options, you limit the number of columns that require data entry. In this example,

there is no need to select any of the other options because your data set contains only complete data.
Weibull++/ALTA Quick Start Guide 5



2  Life Data Analysis

Once the data folio is created, you enter the data given by the bulb supplier, as shown next. 

Once the data set is entered, the next step is to set up the analysis. The analysis options are available in the
Settings area of the control panel. This area provides a quick summary of the analysis settings that will be
used to fit a distribution to the data set. The current settings on the Main page of the control panel are as
follows:

 Rank Regression on X (RRX)

 Standard Ranking Method (SRM)

 Median Ranks (MED)

Note: The new  folio starts with single data sheet by default. You can add multiple data sheets  to  the  folio as

needed. Think of the data folio as an Excel® workbook that can contain multiple worksheets.
6 Weibull++/ALTA Quick Start Guide

 Fisher Matrix Confidence Bounds (FM)



2.1  Complete Data

These settings are also available on the Analysis page of the control panel, which can be accessed by
clicking the Analysis button, as shown next. 

The next step is to set the distribution that you want to fit to the data. In order to determine which
distribution will work best with your data, you click the Distribution Wizard icon on the Main page of
the control panel.

You select to consider all the distributions and then click Analyze to see which of the selected

Tip: Instead of switching between control panel pages, you can click the blue text in the Settings area on the Main

page as a quick method for switching between available analysis options. 
Weibull++/ALTA Quick Start Guide 7

distributions best fits the data set, based on the selected analysis method (in this case, it is for the RRX
analysis method).

Note: The Distribution Wizard serves only as a guide. You should compare its results with your own engineering

knowledge about the product being modeled before making the final decision on which distribution to use for
your data set.



2  Life Data Analysis

The G-Gamma distribution receives the highest ranking, but you know enough about the properties of that
distribution to conclude that it is not the best choice for the type of analysis you are performing. You
decide to use the 2P-Weibull distribution, which received the second highest ranking. To do this, you close
the Wizard and then select 2P-Weibull from the drop-down list on the control panel.

To analyze the data (i.e., fit the selected distribution based on the selected analysis settings), you click the
Calculate icon on the control panel.

Once the distribution is fitted, the Analysis Summary area of the control panel displays the parameters of
the distribution and other relevant information. In this case, based on the 2P-Weibull distribution setting,
the results are as shown next. 

This result includes the Rho, which is the correlation coefficient, and the LK Value, which is the value of 
the log-likelihood function based on the current parameter solution.

You can now access additional information, obtain metrics and/or view plots. To create a probability plot, 
you click the Plot icon on the control panel.

Probability Plots: The Weibull probability plot is drawn on a “Weibull probability plotting paper”
that displays time on the x‐axis using a logarithmic scale, and the probability of failure on the y‐axis
8 Weibull++/ALTA Quick Start Guide

To obtain the results from the plot, you point to the plot line to highlight it, press SHIFT and then click the
plot line. The x and y coordinates for the current position of the mouse pointer will be displayed. You can
hold down the SHIFT key while moving the mouse to read the coordinates from any position on the line.

using a double log reciprocal scale. From the plot, you can obtain the probability of failure at a given
time or vice versa.



2.1  Complete Data

The following example shows the Weibull probability plot with the approximate B10 life of the bulbs
(where the x-axis value corresponds to y=10%).

To add a label that displays the coordinates on the plot, you simultaneously press CTRL and ALT, then
click a point on the plot, as shown next.

You find that one of the disadvantages of reading results off the plot is that it may be difficult to position
the mouse at exact values. To get more precise results, you open the Quick Calculation Pad (QCP) by
Weibull++/ALTA Quick Start Guide 9

clicking the icon on the control panel.



2  Life Data Analysis

The QCP provides quick access to a set of commonly needed results. To estimate the MTTF, you select to
calculate the Mean Life and use the Units drop-down list to make sure that the results will be returned in
hours. You click Calculate. The average time to failure for the bulbs is about 906 hours, as shown next.

Similarly, you use the QCP to answer the remaining questions:

 To estimate the B10 life, you select to calculate the BX% Life and enter 10 for the BX% Life At

Note: The picture shows the QCP without the optional “Calculation Log” on the right side of the window. To hide
or display this log on your computer, click the Options button and then toggle the Show Calculation Log option.
10 Weibull++/ALTA Quick Start Guide

input. The result is about 570 hours. A B10 of approximately 570 hours means that 10% of the
population will be failed by 570 hours of operation.

 You select Reliability to calculate the reliability at 200 hours. The result is 0.998406 or 99.84%.

 To determine the number of bulbs out of 1,000 that would fail after 200 hours of operation, you
first find the probability of failure at 200 hours by selecting Prob. of Failure and entering 200 for



2.2  Censored Data

the time. The probability of failure is 0.001594 or 0.16%. You multiply this by the total number of
bulbs (1,000). The number of bulbs that would fail is 1.6 or approximately 2.

 To estimate the warranty time during which no more than 2% of the bulbs will fail, you select to
calculate the Reliable Life and enter 0.98 for the Required Reliability input. The result is about
377 hours. (Alternatively, the same result could have been obtained by calculating the B2 life.)

2.2  Censored Data

After analyzing the supplier’s data, you decide that you would feel a lot more comfortable if you could
validate the results yourself by performing an in-house test.

After putting in the appropriate requests, you are allocated 15 bulbs for testing purposes and have approval
to use the lab facilities for a maximum of 40 days. Unfortunately, only five pieces of equipment that are
capable of detecting bulb failures are available for you to use. Given this constraint, you decide to test 5
bulbs using the available automated equipment and test the remaining 10 bulbs via manual inspection.
You stop by the lab on your way to your office every morning at 8:00 am (except on weekends and
holidays) to check the status of the 10 bulbs. When you find that one of the bulbs has failed, the only
information you have is that it failed sometime after you last checked on the bulbs (the last inspection) and
before now (the current inspection). This information is called interval censored data.

Once the test is completed (after 40 days or 960 hours), you have the following data:

 For the automated equipment, bulbs 1, 2 and 3 failed at 425, 730 and 870 hours respectively, while

Censored  Data:  Censored  data means  data with missing  information. When  a  unit  has  failed
between observations and  the exact  time  to  failure  is unknown,  the  time  intervals  in which  the
failures occurred are referred to as interval censored data. On the other hand, for non‐failed units
that continue to operate after the observation period has ended, the observed operating times of
the units are referred to as right censored data or suspensions.
Weibull++/ALTA Quick Start Guide 11

bulbs 4 and 5 continued to operate after 960 hours.

 For the manual inspections, you have the log shown on the following page, where  indicates a
working bulb and x indicates a failed bulb. 
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Day Hrs
Bulb 
6

Bulb
7

Bulb
8

Bulb
9

Bulb
10

Bulb
11

Bulb
12

Bulb
13

Bulb
14

Bulb
15

1 24          

2 48          

3 72          

4 96          

5 120          

6 144
Weekend

7 168

8 192          

9 216          

10 240          

11 264          

12 288          

13 312
Weekend

14 336

15 360          

16 384          

17 408          

18 432          

19 456          

20 480
Weekend

21 504

22 528          

23 552          

24 576          

25 600          

26 624        X  

27 648
Weekend

28 672

29 696   X      

30 720        
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31 744        

32 768       X 

33 792       

34 816
Weekend

35 840

36 864      X 

37 888      

38 912      X

39 936     

40 960  X   



2.2  Censored Data

Objectives

 Use a Failure Rate vs. Time plot to ascertain the failure rate behavior of the bulbs. Your
expectation is that the bulbs should have an increasing failure rate. Basically, an increasing failure
rate implies an underlying degradation mechanism with time, or in other words, the older the bulb
the more likely it is to fail.

 Estimate the average bulb life.

 Estimate the B10 life of the bulbs.

 Estimate the reliability of the bulbs for 200 hours of operation.

 Assuming 1,000 bulbs will be fielded, estimate how many would fail after 200 hours.

 Estimate the warranty time for the bulb if you do not want failures during the warranty period to
exceed 2%.

Solution

To answer the questions of interest, you will perform life data analysis on the censored data set that you
obtained from both parts of the in-house test (automated equipment and manual inspection).

First, you create a new Weibull++ standard folio (“Bulb A - In-House Data” in the sample project). When
prompted to specify the data type, you select Times-to-failure data and the following check boxes:

 My data set contains suspensions (right-censored data) 

 My data set contains interval and/or left censored data
Weibull++/ALTA Quick Start Guide 13



2  Life Data Analysis

Once the folio is created, you enter the data obtained from both parts of the test in the data sheet. On the
control panel, you choose the 2P-Weibull distribution and the MLE parameter estimation method. The
resulting data sheet is shown next.

Next, you click Calculate to analyze the data set, and then click Plot to create a probability plot. 

Maximum Likelihood Estimation (MLE): As a rule of thumb, analysts often use the MLE analysis
method when  dealing with  heavily  censored  data,  as  in  this  example.  This  is  because  the MLE
method is based on the likelihood function, which considers the time‐to‐suspension data points in
the estimate of the parameters whereas in rank regression (RRX and RRY), the solution is based on
the plotting positions of the times‐to‐failure data. 
14 Weibull++/ALTA Quick Start Guide



2.2  Censored Data

On the control panel of the plot sheet, you use the Plot Type drop-down list to choose the Failure Rate
vs. Time plot. This displays the failure rate behavior of the bulbs over time. The plot shows an increasing
failure rate, as you suspected.

Using the QCP as before, you again answer the rest of the questions:

 Mean Life = 894 hours. 

 B10 Life = 593 hours.

 Reliability at 200 hours = 0.999198 or 99.92%.

 Probability of failure at 200 hours = 0.000802 or 0.08%. Therefore, when multiplied by 1,000
bulbs, the number of bulbs that would fail is 0.8 or about 1 bulb.
Weibull++/ALTA Quick Start Guide 15

 Warranty time = 410 hours.



2  Life Data Analysis

2.3  Confidence Intervals

Before you submit the results of the in-house test for the projector bulbs, you want to quantify the error
that may be associated with your predictions. After all, the results were based on a sample of only 15
bulbs. If you were to repeat the same experiment with another set of 15 bulbs, you would, in all likelihood,
obtain different results. To quantify the error due to sampling, you will use confidence intervals (or
confidence bounds), which may be viewed as the range of probable values that you are likely to obtain if
you were to keep repeating the same experiment with different samples of 15 bulbs, all belonging to the
same homogeneous population.

One‐Sided or Two‐Sided Confidence Bounds: Confidence bounds may be one‐sided or  two‐
sided. They are usually around a computed metric, such as the reliability at a given time. Two‐
sided bounds are used to indicate that the metric of interest is contained within these bounds with a
probability equal to the chosen confidence value. For example, 90% two‐sided confidence bounds
indicate that the metric of interest will be between the bounds 90% of the time, and that 5% of the
time  it may be  above  the upper bound  and  5% of  the  time  it may be below  the  lower bound.
Another way to express this is to say that the metric of interest will lie between the bounds with a
90% probability.

One‐sided bounds, on the other hand, are used to indicate that the metric of interest is above the
lower bound with a probability equal to the chosen confidence value. For example, a 90%  lower
one‐sided confidence bound indicates that the metric of interest will be higher than the lower bound
with a 90% probability. 

90% 90% 90%

5% 5% 10% 10%
16 Weibull++/ALTA Quick Start Guide

An estimated metric that is obtained without the use of confidence bounds is said to be at the 50%
confidence level, or the error is equal on both sides.

X X XY

2-sided confidence bounds Lower 1-sided confidence bounds Upper 1-sided confidence bounds



2.3  Confidence Intervals

You use the QCP to calculate the MTTF of the bulb. To obtain the desired confidence bounds, you choose
Two-Sided from the Bounds drop-down list and enter 0.90 for the Confidence Level input. The
calculated results are shown next. 

Therefore, with a 90% probability, the true value of the MTTF is estimated to be between 790 and 1,010
hours. While unlikely, there is still a 5% probability that the MTTF is less than 790 hours and a 5%
probability that it is greater than 1,010 hours.
Weibull++/ALTA Quick Start Guide 17



2  Life Data Analysis

To visualize the confidence bounds, you create a Weibull probability plot. To show the bounds, you right-
click the plot sheet and select Confidence Bounds. You then select to display the Two-sided bounds. The 
following plot shows the 90% two-sided confidence bounds on the Weibull probability plot (with the 
scaling adjusted to Y = 0.1 to 99 and X = 100 to 10,000).

2.4  Comparing Data Sets

After analyzing the data from the bulb supplier and the in-house test, a reasonable question would be, how
do they compare? Specifically, you want to understand how the data and analysis from the in-house test
compare to the data and analysis provided by the bulb supplier. One way to do this is to use an overlay plot
that displays both data sets and analyses on the same plot. You create the overlay plot by choosing Insert
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> Reports and Plots > Overlay Plot. 

When prompted to select which data sets to plot, you select the folio containing the data set from the
supplier and the folio containing the data set from the in-house test. (“Bulb A - Supplier Data” and “Bulb
A - In-House Data” in the sample project.)
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The following overlay plot (“Bulb A - Supplier vs. In-House” in the sample project) shows the two data
sets plotted on the same Weibull probability plot (and both with 90% two-sided confidence bounds):

The overlay plot shows that the probability lines of the two data sets have similar slopes. Furthermore,
there is a significant overlap in the confidence bounds of both sets, which suggests that both data sets
exhibit the same reliability characteristics. 

Another way to determine whether there is a statistically significant difference between the two data sets
at a given confidence level (say 90% confidence level for this example), is to switch the plot type to a
Contour Plot. When prompted to specify the contour lines, you select the 2nd Level, 90% check box. 

Tip: To add contour lines (confidence levels) to the plot or change the confidence level associated with a contour
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You add labels to the plot by holding down the CTRL key and then clicking in the plot. You then edit the
text by double-clicking the labels. To position the text on the plot, you click the label and then drag it by
its handle (i.e., the small box on the upper left corner of the label), as shown next.

line, click the Contours Setup link on the control panel of the plot sheet.
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The annotated plot is displayed next (with the scaling adjusted to Y = 0 to 9 and X = 0 to 1,500). The
contour plot shows that the two data sets overlap at the 90% confidence level; therefore, they do not show
a statistically significant difference at that confidence level. 

Tip: For more extensive annotations you can use the RS Draw utility, which is a metafile graphics editor that

allows you to insert text, draw objects, paste another picture into the plot and rearrange the objects in the
plot. You can open the utility by clicking the RS Draw icon on the control panel. 
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2.5  Reports

For presentation to the rest of the team, you will prepare some reports that summarize the results of your
analyses. Each of the built-in reporting tools in Weibull++ — analysis workbooks and Word report
templates — offers different advantages. You will use both tools for this situation.
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Objectives

 Use an analysis workbook to automatically calculate all of the results that you obtained
individually from the QCP. 

 Use a Word report template to create a document that presents some key results from both analyses
(MTTF and B10 life) along with a plot of the failure rate vs. time.

 Create another sheet in the analysis workbook that can be used to evaluate the expected number of
failures for different time intervals, and determine which time interval will have the greatest
number of failures.

2.5.1  Analysis Workbook

To create an analysis workbook that contains all of the individual QCP results automatically calculated in
the same worksheet, you choose Insert > Reports and Plots > Analysis Workbook (“Bulb A - Supplier
Data” in the sample project). 

When prompted to specify a default data source, you choose the folio containing the bulb supplier’s data
and click OK to create a blank workbook.

You build a worksheet like the one shown next (“Analysis Workbook - Bulb A” in the sample project) by
using the Function Wizard to build functions that automatically insert calculated results based on the
specified data source.
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For example, to build the function that is highlighted in the picture, you open the Function Wizard by
clicking the icon on the control panel.

You select the AMEAN function from the function list, as shown next.

The AMEAN (i.e., MTTF) function doesn't have any required inputs, and the confidence level input is
optional (as indicated by the brackets that enclose the label) and not applicable in this example. So you
simply specify the data source by selecting the Use Default check box. From the Data Source Index
drop-down list, you select the number 1 (i.e., the first default data source, which you selected when you
created the workbook), then you click Insert.
22 Weibull++/ALTA Quick Start Guide

The MTTF for the specified data set will be automatically computed and displayed in the workbook. You
continue to use the Function Wizard to build the rest of the report: 

 To calculate the B10 life, you select the TIMEATPF function and enter 0.1 for the Unreliability
input.

 To calculate the reliability at 200 hours, you select the RELIABILITY function and enter 200 for
the Age input.

 To calculate the expected number of failures after 200 hours of operation, you first calculate the
probability of failure and then multiply that number by the total number of bulbs (1,000 bulbs in
this example). To do this, you enter the following formula directly into the appropriate cell in the
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analysis workbook: =(1 - B7)* 1000, where B7 is the cell reference of the reliability at 200 hours,
as shown in the picture on page 21.

 To calculate the B2 life (which is equivalent to the warranty time during which no more than 2% of
the bulbs will fail), you select the TIMEATPF function and enter 0.02 for the Unreliability input.

You choose Sheet > Format and View to format the text in the worksheet.

Once you have completed the worksheet, you save it as a template that can be used in the future for any
other analysis. To do this, you choose Workbook > Actions > Save Workbook as Template.

The template file (*.wrt) is now stored in the location you specified and will be accessible from within the
Analysis Workbook Wizard each time you create a new workbook. For example, to create a workbook that
shows the results from the in-house test data, you choose Insert > Reports and Plots > Analysis
Workbook to open the Wizard again. 

This time, you select the in-house data folio (“Bulb A - In-House Data” in the sample project) as the
default data source. You then select the Based on Existing Template check box and click the User tab. 

You click the Open button and browse for the *.wrt file you just saved. (Note that if the template had been
opened recently on this computer, the path and filename would be displayed in the list and you could
simply double-click the name to open it again.)
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When you click OK, the new workbook contains all of the analysis results automatically calculated for the
in-house data set. 
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2.5.2  Word Report Template

To create a document that presents key results and plots for both data sets, you choose Insert > Reports
and Plots > Word Report Template (“Bulb A - Supplier Data” in the sample project).

When prompted to specify a default data source, you choose the folio containing the bulb supplier’s data
and click OK to create a blank workbook.

When the template opens, you click the Associate Data Sources icon on the control panel so you can add
the in-house data as the second default data source (each report can be associated with up to four data
sources at a time).

The Associate Data Sources window is shown next, with the in-house data set already added as a second
data source.
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You build a report template like the one shown next (“Word Report - Bulb A” in the sample project) by
using the Function Wizard and Plot Wizard to insert functions into the desired locations. You also use
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some of the more flexible formatting options that this tool provides for enhancing the presentation quality
of the report.
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For example, to insert the name of the standard folio/data sheet that the results were obtained from (i.e.,
the [DATASOURCENAME(1)] function in the sample report), you open the Function Wizard by
clicking the icon on the control panel.
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You select the Data Source Name function from the function list. You also select the number 1 for the
data source index. You then click Insert to add the function to the report template. You continue to build
the report using a similar process for the other functions. 

To insert the Failure Rate vs. Time plot, you open the Plot Wizard by clicking the icon on the control
panel.

You select the Failure Rate vs. Time plot from the plot list. You also select the number 1 for the data
source index. You then click Insert to add a placeholder for the plot in the report template. 

To resize a plot, you select its placeholder in the report template, and then click and drag the resize handles
(i.e., the small circles that appear within the corners of the selected placeholder).

When you have finished building the report template, you generate the report by clicking the Create
Report icon on the control panel.

This creates a Microsoft Word document with the data inserted in the report, as shown next.
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2.5.3  Building Tables and Using Custom Functions

To evaluate the expected number of failures for different time intervals, you create another worksheet in
the analysis workbook (“Analysis Workbook - Bulb A” in the sample project), by choosing Workbook >
Worksheet > Insert Sheet. 

You double-click the name of the new worksheet (located at the bottom of the window) and rename
“Sheet1” to “Expanded Workbook.” Next, you build a worksheet like the one shown next by building a
table and creating custom functions.
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The results in the table show that for a sample size of 1,000 bulbs, the interval from 900 to 950 hours will
have the greatest number of failures, about 76.
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The following picture shows the formulas in the worksheet (by selecting the View Formulas check box
on the control panel).

For example, in the Time column, instead of manually entering the times at 50 hour intervals, you enter a
start time in cell A7 and then enter a formula directly in cell A8 that automatically adds 50 hours to the
previous time (e.g., “=A7 + 50” where A7 is the cell location of the start time). You then copy this formula
by clicking inside cell A8 and then dragging the fill handle (the small black square on the lower right of
the cell) down the column of cells. 
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In the Reliability column, you use the function wizard to insert a function that calculates the reliability at
an interval (e.g., “=RELIABILITY(Default1,A7)” where A7 is the cell location of the time that the
reliability will be calculated for). You copy this function down the column of cells as well.

In the Cumulative Number of Failures column, you build a custom function to calculate the cumulative
number of failures by the end of each interval for a given sample size. You use the function wizard to
insert the ROUND function to round the result to 2 decimal places. You then modify the input for the
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function directly in the cell (e.g., “=ROUND((1-B7)*$B$4,2)” where “1-B7” gives you the probability of
failure for the value calculated in B7, and the absolute reference to cell $B$4 supplies the sample size). 

In the Number of Failures per Interval column, you enter a formula directly in the cell to calculate the
number of failures by interval. (e.g., “=C8-C7” where C8 is the cumulative number of failures after 150
hours and C7 is the cumulative number of failures that had already occurred by 100 hours).

Tip: An absolute reference points to a cell at an exact location. When the cell containing the function is copied,

the reference does not change. Absolute references are designated by placing a dollar sign ($) in front of the row
and/or column that is to be absolute.
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Degradation analysis is useful for tests performed on highly reliable
products that (a) cannot feasibly be tested to complete failure under normal
operating conditions, (b) are associated with a measurable performance
characteristic (e.g., the wear in brake pads) and (c) are not destroyed upon
inspection. This analysis consists of two steps. First, the failure times of the
units on test are extrapolated using measurements of their degradation over
time. (A unit is considered failed when its degradation reaches a specified
critical level.) Second, once these failure times are obtained, life data
analysis is used to estimate the reliability of the product.

In this chapter, you will use a degradation analysis folio to analyze the measurements of an LED lamp’s
decreasing light output.

3.1  Simple Degradation Analysis Using Luminosity Measurements

After completing the life data analysis for the projector’s incandescent bulb, you learn that the R&D group
is working on perfecting an LED lamp to replace the bulb. The product engineers would like to obtain

Degradation Analysis 3

 Degradation 
folios

 Analyzing 
extrapolated 
failure times

 QCP and plots

Watch a video of this example at 
http://www.ReliaSoft.tv/weibull/startguide/weibull_qsg_3.html.
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reliability information for the new lamp. However, while it is relatively easy to test incandescent bulbs to
failure (given their low life in hours), testing LEDs to failure is not feasible given their long life
characteristics. Based on the failure mode under consideration for the LEDs, you know that the failure is
gradual and preceded by a decrease in light output of the lamp over time. As a result, the R&D group
concludes that in lieu of a long failure test, it is preferable to perform a degradation analysis where they
will monitor the decrease of light output over time and use this information to extrapolate failure times.

http://www.reliasoft.tv/weibull/startguide/weibull_qsg_3.html
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According to the formal test plan, the light intensity of 10 lamps will be recorded at 400, 600, 800 and
1,000 hours of operation. This data set will be used to predict the lamp’s life. Furthermore, the engineers
agree that the lamp should be considered failed when its output reaches 50% of its design output of 1,000
lumens.

The following measurements were obtained in the test:

Luminosity Measurements (in Lumens) of 10 LED Lamps

Objectives

 Use a Degradation vs. Time plot to see how the luminosity of the lamps degrades over time.

 Estimate the following metrics:

 The average lamp life (i.e., MTTF or mean life)

Inspection 
Time (Hr)

Lamp 
01

Lamp 
02

Lamp 
03

Lamp 
04

Lamp 
05

Lamp 
06

Lamp 
07

Lamp 
08

Lamp 
09

Lamp 
10

400 960 950 990 840 880 800 930 870 870 910

600 890 900 890 730 760 770 890 810 800 850

800 850 860 830 670 710 730 840 760 730 800

1,000 810 820 780 615 670 700 820 730 690 770

Degradation Analysis Assumptions: Degradation analysis can be used for analyzing this data set
because, according to the underlying physics, the  luminosity will continue to decrease with time.
The main  assumption  in  this  kind  of  analysis  is  that  the  degradation mechanism  and  observed
measurements will continue the same behavior throughout operation. In other words, this analysis
assumes that the measurements will monotonically decrease (or increase) with time.
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 The B10 life (i.e., the time by which 10% of the lamps will be failed)

 The reliability for 200 hours of operation

 The number of lamps (out of 1,000) that can be expected to fail after 200 hours

 The warranty time on the lamp if you do not want failures during the warranty period to exceed
2%



3.1  Simple Degradation Analysis Using Luminosity Measurements

Solution

You start by choosing Insert > Folios > Weibull++ Degradation (“Degradation - LED Lamp” in the
sample project) to create a new degradation analysis folio. Then, you enter degradation measurements into
the folio’s data sheet and enter 500 for the lamp’s Critical Degradation (i.e., the luminosity level at
which a lamp is considered failed).

First, you need to specify how failure times will be extrapolated from the luminosity measurements. The
failure mode under consideration is metal fatigue, and you know the underlying degradation model for
this failure mode is the power model, so you select Power from the drop-down list in the Degradation
Model area. Next, you need to specify how the extrapolated failure times will be analyzed. Based on your
engineering knowledge, you select 2P-Weibull from the Life Data Model area.

In the Settings area of the control panel, you click the blue text to switch between the available analysis
options. (Note that these settings are also displayed on the Analysis page.) You select the following:

 Rank Regression on X (RRX)

 Standard Ranking Method (SRM)

 Median Ranks (MED)

 Fisher Matrix Confidence Bounds (FM)

Next, you click the Calculate icon to analyze the data.
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The folio appears as shown next.

Before you continue, you decide to quickly review the results of the software’s calculations. To see how
the failure times were extrapolated, you click the Degradation Results (...) button. You look at the
34 Weibull++/ALTA Quick Start Guide



3.1  Simple Degradation Analysis Using Luminosity Measurements

Degradation Fit Results tab (shown next) to see the parameters of the degradation model that was fitted to
each lamp.

Then you look at the Extrapolated Failure/Suspension Times tab to see the failure times that were
extrapolated, as shown next.
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To see the results of the life data analysis that was performed on the extrapolated failure times, you return
to the control panel and click the Life Data Results (...) button.

Next, to view a plot that shows how the luminosity for each unit on test degraded over time, you click the
Plot icon on the control panel and select the Degradation vs. Time (Linear) plot. This shows you the
degradation lines for each LED lamp.

To improve the appearance of the plot, you clear the check boxes in the Scaling area and enter the
following ranges:

 Y-axis: 450 to 1,000 lumens

 X-axis: 300 to 3,000 hours
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The resulting plot is shown next. The horizontal line towards the bottom of the plot marks the luminosity
level at which the lamp is considered failed.

Next, to solve for the requested reliability metrics, you open the Quick Calculation Pad by clicking the
QCP icon on the control panel.
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You select to calculate the Mean Life and use the Units drop-down list to make sure the results will be
returned in hours. The mean life of the lamp is estimated to be about 11,145 hours, as shown next.

You continue to use the QCP to solve for the remaining reliability metrics:

 You select BX% Life to calculate the time by which 10% of the lamps will be failed. The result is
about 1,913 hours.

 You select Reliability to obtain the reliability at 200 hours of operation. The result is 0.993465, or
99.3465%.

 To solve for the upper bound on the number of LED lamps (out of 1,000) that would fail after 200
hours, follow these steps:
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 Select Prob. of Failure and enter 200 for the mission end time to calculate the probability of
failure at 200 hours.

 The probability of failure at 200 hours is estimated to be 0.006535 or 0.65%. Now multiply this
by the total number of lamps (1,000). The number of lamps that will fail is 6.5, or
approximately 7.

 To estimate the warranty time during which no more than 2% of the lamps will fail, you select to
calculate the Reliable Life, and then enter 0.98 for the Required Reliability input. The result is
about 499 hours. Alternatively, the same result could have been obtained by calculating the B2
life.



z

Weibull++ includes a number of test design tools that provide ways to
design reliability tests and evaluate/compare proposed test designs. In this
chapter, you will work with the three tools available in the Test Design folio,
starting with the Reliability Demonstration Test tool, which you will use to
design a zero-failure test intended to demonstrate a specified reliability for
bulb A.

Afterwards, you’ll examine ways to compare the reliability of bulb A and a
less expensive bulb B. To do this, you’ll use the Difference Detection Matrix
to determine what test times are required to demonstrate a difference in
reliability between the two bulbs. Then you’ll use the Expected Failure Time
Plot to compare the failure times that are expected from a design with a
specified reliability to the actual failure times that are observed during a test.

4.1  Combining the Test Data for Bulb A

Before you can use the test design folio, you need to estimate the life distribution followed by bulb A. You

Design of Reliability Tests 4
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Watch a video of this example at 
http://www.ReliaSoft.tv/weibull/startguide/weibull_qsg_4.html.
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already have data from two tests for the bulb, and you established previously that there is no significant
difference between the two data sets (see Chapter 2). You decide to combine the data sets and analyze
them in a separate standard folio (“Bulb A - Combined Data” in the sample project). The analysis shows
that the failure behavior of bulb A follows a 2-parameter Weibull distribution with beta = 4.219615. Using
the Quick Calculation Pad, you also see that the estimated B10 life of the bulb is about 581 hours.

4.2  Reliability Demonstration Test Design

Based on your experience with analyses for bulb A, which is currently being used in the projector, you are
asked to design a demonstration/validation test to show that the bulb has the required B10 life.

http://www.reliasoft.tv/weibull/startguide/weibull_qsg_4.html
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More specifically, your objective is to demonstrate that bulb A has a B10 life of at least 500 hours with
80% confidence. You are allocated 10 bulbs for the test and decide on a zero-failure reliability
demonstration test. In other words, you decide to design a test that uses the available sample size of 10 and
will demonstrate the target metric if no failures occur before a certain time (i.e., you design a test where
the number of “allowable” failures is zero).

Objectives

 Determine the test time for a zero-failure test that would demonstrate the target metric with a
sample size of 10.

 Compare the test times that would be required given different sample sizes and different numbers
of “allowable” failures.

Solution

To create a new test design folio (“Zero-Failure Test - Bulb A” in the sample project), you choose Insert
> Tools > Test Design.

In the Test Design Assistant that appears, you select Reliability Demonstration Test Design. Since you
are able to make reasonable assumptions about the life distribution that describes bulb A’s failure rate
behavior, you select the Parametric Binomial test design method on the control panel of the folio. To

Zero‐Failure Tests: A zero‐failure test is appropriate in this case because you only want to know,
with a given confidence level, whether the life metric is greater than the specified requirement. This
sort of test provides a quick and efficient way of accomplishing this. Note, however, that zero‐failure
tests generally cannot be used  to determine  the actual value of a product’s  life metric.  (In some
special cases, the 1‐parameter Weibull or 1‐parameter exponential distribution can be suitable for
analyzing a data set containing few or no failures.)
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specify the metric that you wish to demonstrate, you choose Reliability value at a specific time from the
Metric drop-down list on the RDT sheet. Then you enter 90 for the reliability and 80 for the confidence
level. (The B10 life is equivalent to the time at which reliability reaches 90%.)

Next, you click the Get Distribution icon and select the standard folio that analyzed the combined data
sets for bulb A (“Bulb A - Combined Data” in the sample project).

This copies the life distribution from the standard folio into the Distribution and With this Beta fields of
the tool, and it calculates the time at which bulb A would reach the specified reliability with the specified
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confidence level (i.e., the B10 life). The calculated time is about 581 hours, and it appears in the At this
time field. 

You check to make sure the B10 life is equal to or greater than the B10 life you wish to demonstrate (i.e.,
500 hours). Since it is greater, you know a demonstration test is possible, and so you continue planning the
test by changing the value in the At this time field to 500.

In the Solve for this value area, you select to solve for the Required test time for a test with a sample
size of 10. To specify that this will be a zero-failure test, you enter 0 for the maximum number of failures.
Finally, you click the Calculate icon. The inputs and results appear as shown next.

Based on this calculated result, you need to test the 10 bulbs for at least 553 hours each. If no failures
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occur during that time, you will have demonstrated that the bulb has a B10 life of at least 500 hours with
80% confidence (i.e., if no failures occur before about 553 hours, then there is an 80% probability that the
B10 life is greater than 500 hours).

You would also like to explore the possibility of using a different sample size and examine the sample
size’s effect on test time. This may allow you to find a better combination of sample size and test time. So
you click the Show RDT Table icon on the control panel.
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A sheet called “Table of RDT” is added to the folio. You select to solve for the Test time for given
sample size and specify that you want to see the required test times for sample sizes that range from 5 to
20, using an increment of 1. Then, because you want to view test times for zero-failure and 1-failure tests,
you specify that you want to consider numbers of failures that range from 0 to 1. Finally, you click
Calculate and see the results shown next.

This table uses the target metric and life distribution information you provided earlier to calculate the test
times needed under many different scenarios. For example, the first highlighted cell shows that you could
reduce the sample size to 7 and test to 602 hours instead of 553 (with zero failures). The second
highlighted cell shows that if you were to stay with your current sample size of 10, you could demonstrate
the target metric even if 1 failure occurred. However, the required test time in that case would increase to
649 hours.
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To more easily see how sample size, test time and number of failures are related, you generate a plot of
this information by clicking the Plot icon. The plot is shown next.

4.3  Difference Detection Matrix

The Reliability Demonstration Test tool is used to plan a test that is intended to demonstrate that a
product’s reliability exceeds a specified target. Sometimes, however, tests will be performed just for
comparative purposes (e.g., to show that one product’s B10 life is greater than another product’s). The
Difference Detection Matrix calculates how much test time is required before it is possible to detect a
statistically significant difference in a reliability metric (e.g., mean life) of two product designs by
analyzing the data from a reliability life test.
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The purchasing group has located a less expensive bulb B from another manufacturer. Based on the
extremely attractive pricing of bulb B, you are asked to evaluate and propose plans to compare the B10
life of bulb B to the life of bulb A. You are also informed that you only have 5 units of bulb B available for
testing. The goal of the comparison is to determine if there is a significant difference between the B10
lives of the bulbs at a specified confidence level. Because of the smaller sample size, you decide to use a
confidence level of 70%.

You realize that you could simply test bulb B and compare the results to the results obtained from testing
bulb A. However, given that only 5 units of bulb B are available for testing, you decide to first explore the
capability of a test (and the available sample sizes) to show any difference. In other words, you will be
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evaluating various test durations to determine which durations are capable of demonstrating a difference
in B10 life between the two bulbs.

Objective

 Determine how long you must test the 5 units of bulb B to be able to detect a difference in the B10
life of the two designs.

Solution

You start by choosing Insert > Tools > Test Design and then selecting Difference Detection Matrix in
the Test Design Assistant. The new matrix (“Difference Detection - Bulb A vs. Bulb B”) will allow you to
see what test times will be required to show a difference between the bulbs, given a range of different B10
life values.

On the control panel of the new folio, you specify that you will be comparing the B10 life by choosing
BX% Life and entering 10 in the Metric to Compare area. You enter 70 for the confidence level and
choose Hour (Hr) for the time units, as shown next.

You provide information about the sample size and life distribution of bulb A in the Design 1 area, and
you provide this information for bulb B in the Design 2 area. The results from combining and analyzing
the 25 data points from the in-house test and the supplier’s data (“Bulb A - Combined Data” in the sample
project) show that bulb A has a 2P-Weibull distribution with a beta of about 4.2. Since you will be testing
the assumption that bulb A and bulb B have a similar reliability, you assume the same life distribution
information for both products.
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The fields in the Reliability Metric Setup area define the range of reliability metric values in which you
want to see the results. Given that bulb A has a B10 life of about 600 hours, a reasonable range may be
from 0 to 1,000, so you enter 1000 in the Max Metric Time field. To specify that you would like to see
the results spread out over 50-hour increments, you enter 50 in the Metric Increment field.

The inputs in the Test Time Matrix Setup area define the test durations that you want to explore. After
reviewing the analyses of bulb A, you set the range to have a maximum of 2,000 hours of test time and
decide to have the software give you results at 9 other intervals. You do so by entering 10 in the Number
of Test Times field, and then you clear the Calculate Test Times check box and enter the specific test
times shown next.

With these settings, the software will evaluate test plans with ten different durations: 2,000 hours, 1,500
hours, and so forth.
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With all the inputs provided, you click the Calculate icon to generate the matrix. Part of the matrix is
shown and explained next.

Since the B10 life of Design 1 (bulb A) was estimated to be 581 hours, you can focus on either the 550
column or the 600 column. You choose to focus on the 550 column, as shown above. (You decide not to
change to a 10-hour increment to view the 581 hours column, since that would make the matrix quite
large.)

You do not know what the life of Design 2 is; thus, you are interested in the range of life values that you
specified on the control panel. The legend assigns an index number to each of the 10 test durations you
specified in the Test Time Matrix Setup area. In this case, the index number represents the test time that
would be needed to detect a difference in B10 life with 70% confidence.

For example, suppose Design 2 has a B10 life of 350 hours. The index number in row 350 is 5, which
corresponds to a test time of 600 hours. According to this result, if Design 2 has a B10 life that is equal to
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or less than 350 hours (and failure rate behavior that is similar to Design 1; in other words, behavior that
follows a Weibull distribution with beta = 4.2), then if you tested 5 bulbs from Design 2 using the
indicated test time, you would detect a difference between the designs 70% of the time (i.e., the difference
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would be demonstrated with 70% confidence). You click the cell to view the required test time and the
confidence bounds that were used to determine that the test time demonstrate a difference.

Similarly, if Design 2 has a B10 life of 700 hours, then the index number is 4, which means that testing 5
of the bulbs for 800 hours would demonstrate a difference in B10 life with 70% confidence.

Furthermore, if the B10 life of Design 2 is greater than 350 hours but less than 700 hours, then the index
assigned is 0, which means that even a test of 2,000 hours is incapable of demonstrating, at the specified
confidence level, a statistically significant difference between the two designs.

4.4  Expected Failure Time Plot

Before performing a reliability life test, you can use the Expected Failure Time Plot to provide an overall
expected timeline and sequence of events for the test. This in turn can be used during the actual test to
monitor its progress for any early warnings that indicate a deviation from the original assumptions or
expectations.

Tip: The granularity of  the  results  is based on  the  test  times  specified  in  the Test Time Matrix Setup area.  If

needed,  you  can  iteratively  adjust  the  test  times  and  recreate  the matrix  in  order  to  arrive  at  an  optimal
granularity.
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After a discussion with management, you are asked to go ahead and run the life test on the five bulbs. 

Objectives

 Use the Expected Failure Time Plot to determine what range of failure times you can expect to
observe on each unit of bulb B during this test. Assume that bulb A and bulb B have the same
reliability.

 As the units of bulb B fail during the test, compare the failure times to the expected times. If the
bulbs appear to differ in reliability, determine which has a greater B10 life.
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Solution

To create the plot, you choose Insert > Tools > Test Design and select Expected Failure Time Plot in the
Test Design Assistant. In the Plot Setup area on the control panel, you enter 5 for the sample size and 70
to specify that you wish to see 70% two-sided confidence bounds for each expected failure time. You enter
1 for the acceleration factor because the units will be tested under normal stress conditions.

You need to associate the plot with the combined data for bulb A. To do this, you click the Get Failure
Model icon on the control panel and select the calculated data sheet that contains the combined data from
the manufacturer (“Bulb A - Combined Data” in the sample project).

The information in the Expected Failure Model area of the control panel is now updated with the
distribution and parameters that were calculated from the selected data sheet. You click the Redraw Plot
icon to display the ranges of expected failure times (“Expected Failure Times - Bulb B” in the sample
project), and then you adjust the x-axis range so the maximum value is 1,500. The plot appears as shown
next.
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This plot uses the failure number on the y-axis (1 = the first failure, and so on) and time on the x-axis.
Based on the plot, you expect the first failure to occur sometime between 440 and 787 hours of testing, the
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second between 635 and 928 hours, and so forth. You view the actual time bounds by pointing to the first
or last tick mark on a line, as shown next for the first failure.

As the test progresses, you observe the first failure at 300 hours, which is earlier than the associated
starting interval. You conclude that, at the specified confidence level, bulb B’s reliability is less than what
was assumed. In order to estimate the bulb’s B10 life, you continue the test to collect more data. The next
2 failures are observed at 440 and 495 hours. As these failures occur, you display them on the plot by
clicking inside the Actual Failures field on the control panel and entering them into the table that appears.
After recording these 3 failures, the table appears as shown next.

The  Expected  Failure  Time  Plot:  In  general,  this  plot  tells  you  that,  based  on  the  assumed
distribution,  you  can  expect  the  observed  failure  times  to  be within  the  ranges  shown.  If  any
sequential observed time is outside this range, then the distribution (and thus the reliability) of the
observed units  should no  longer be assumed.  (The plots  results are only  valid, however,  for  the
confidence level chosen.) Moreover, if any of the observed failure times is earlier than its predicted
interval, then you can infer that the reliability will be less than what was assumed. Similarly, if any of
the actual failure times is greater than its predicted interval, then you can infer that the reliability is
greater than what was assumed (at the specified confidence level).
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The plot appears as shown next. With three failure times observed, you end the test at 500 hours and
calculate the data.
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You create a standard folio for the bulb B data (“Bulb B - In-House Data” in the sample project) and use
the QCP to calculate the B10 life.
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The estimated B10 life for bulb B is about 280 hours, which is clearly less than the 575-hour B10 life that
was calculated for bulb A using the combined data.

You decide to perform further analysis to determine whether this is a statistically significant difference. To
do this, you choose Insert > Reports and Plots > Overlay Plot (“Bulb A vs. Bulb B” in the sample
project) and select to compare the data sheets for the two bulbs. On the control panel of the overlay plot,
you click Confidence Bounds and then select to view the 70% two-sided bounds on reliability. Finally,
you click Target Reliability on the control panel and select to display the target reliability value of 90%.
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This will mark the time at which reliability equals 90%, which is equivalent to the B10 life. The plot
appears as shown next (with annotations added via RS Draw to make the plot easier to interpret).

The horizontal line marks the target metric, and you can see that bulb B’s B10 life is lower than that of
bulb A, and that the confidence bounds on the B10 life for both products do not overlap. Thus, you
conclude that bulb B indeed has a lower B10 life. You show the plot to the design team and recommend
that they use bulb A in the projector.

Note: In the difference detection matrix you created in Section 4.3, you can see that if the B10 life of bulb B is

300 hours and the B10  life of bulb A  is approximately 550 hours, then a 500‐hour test with a sample size of 5
would be sufficient to detect a difference (at a 70% confidence level) between the designs. Notice that the results
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in this section are consistent with the prior results and that a difference was detected on this 500‐hour test.



Development testing allows you to uncover and correct reliability problems
before a product is deployed; however, there are instances when a problem
is not discovered until the product is in the customer’s hands. Data obtained
from field failures can provide valuable information about how a product
actually performs in the real world. 

In this chapter, you will extract life data from warranty returns records, and
then compare the results obtained from the field data to the results obtained
from an in-house reliability test.

5.1  Warranty Data Analysis

Based on your prior analyses, you recommended bulb A because of its higher reliability; however, bulb B
is lower-priced, and so a decision was reached by management to use bulb B for production. The
projectors with bulb B were then released to market with a 12-month warranty.

Warranty Analysis 5

 Warranty data 
analysis

 Nevada chart 
format

 Forecasting 
product returns

Watch a video of this example at 
http://www.ReliaSoft.tv/weibull/startguide/weibull_qsg_5.html.
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Soon after the product introduction, due to excessive returns (as you predicted), management decided to
discontinue the use of bulb B and return to bulb A, which you originally recommended. Specifically, bulb
B was used in production for twelve months. After that, any projectors released in the 13th month and
beyond were modified to use bulb A. Six months after this change, you are asked to forecast the warranty
returns due to bulb failures for the next six months. The returns data are available and shown in the
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following table. The data set is organized in Nevada chart format. The data includes all 18 months of
service (12 with bulb B and 6 with bulb A).

In this format, the columns represent the warranty returns periods and the rows represent the sales periods.
This chart indicates, for example, that a total of 18 units were returned during the 3rd month (column 3),
and that 13 of those units were sold in the first month (row 1) while 5 units were sold in the 2nd month
(row 2). The rest of the chart can be read in a similar manner.

Objectives

 Assuming an average sales of 1,000 projectors per month, estimate the number of warranty returns
due to bulb failures that will occur in the next six months (i.e., months 19 to 24).

 As a side analysis, verify whether an assumption of a usage rate of 50 hours/month per projector
holds true for bulb B. Do this by comparing the record of warranty failures to the data from the in-
house test of the bulb. See page 47 in Chapter 4.

Solution
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To create a warranty analysis folio (“Warranty - Bulbs” in sample project), you choose Insert > Folios >
Warranty. 

When prompted to specify the data format, you select I want to enter data in the Nevada chart format,
and then click Next. 

Currently, there are 18 sales periods (i.e., the projectors with bulb B were sold in the first 12 months and
the projectors with bulb A were sold in the following 6 months) and 18 returns periods. You are asked to
forecast the returns for the next 6 months, so you include the forecasted future sales for the next 6 months.



5.1  Warranty Data Analysis

Note that because all new projectors have bulb A in them, the future sales will be of projectors with this
type of bulb. You set up your Nevada chart with the following settings:

Note: In the Warranty Folio Setup window, you could select to label the periods in terms of months instead of

numbers; however, the setup will require you to specify the calendar year. This example does not analyze several
years of data, so we will simplify the data entry process by labeling the periods in terms of numbers instead of
months.
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Once the folio is created, you click the Change Units icon on the control panel. 

You then specify that the time units of the sales and returns periods will be in terms of months. 



5  Warranty Analysis

Next, you enter data in the Sales data sheet. You use the assumption of a constant rate of sales of 1,000
projectors per month, and use the subset ID column to specify the type of bulb that was used in the
projectors that were sold that month. 

The resulting Sales data sheet is shown next.

You then enter the data from the Nevada chart on page 54 to the “Returns” data sheet of the folio.

On the control panel, you select the Use Subsets check box, as shown next.

Note: Subset IDs allow you to separate the full data into different homogeneous data sets. In this example, there

are  two  products,  bulb  A  and  bulb  B.  Separating  the  data  by  product will  allow  you  to  fit  different models
(distribution and parameters) to each one.
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This setting tells the software to look at the information in the subset ID column and separately analyze
the data based on their subset IDs. In addition, it allows you to use the drop-down list to switch between
subset IDs and alter the analysis settings for each one, if appropriate. As a general rule, however, the
recommendation is to use the same analysis settings for all subsets. You select the following analysis
settings for each subset ID:

 2P-Weibull 

 Maximum Likelihood Estimation (MLE)

 Standard Ranking Method (SRM)

 Median Ranks (MED)

 Fisher Matrix Confidence Bounds (FM)

Next, you select the Suspend After check box and enter 12 periods. 

Once the settings are finalized, you analyze the data sheet by clicking the Calculate icon on the control
panel.

The Analysis Summary area of the control panel will display two sets of parameters (because the data
sheet contains two subsets IDs). You view the parameters of each set by choosing the subset ID from the
drop-down list, as shown next. The following picture shows the 2P-Weibull parameters of bulb B.

Note:  In many cases, data after  the warranty period are  incomplete or unreliable. The Suspend After setting

allows you to ignore any failure times after the specified period and treat them as suspensions (i.e., all we know is
that the units had not failed by that time). 
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The following picture shows the 2P-Weibull parameters of bulb A.

With the analysis completed, the next step is to generate the forecast. You do so by clicking the Forecast
icon on the control panel.

In the setup window, you set the forecast to start on the 19th month and show 6 periods, as shown next.

The forecast is then generated within the folio and displayed in the data sheet called “Forecast.”

On the control panel of the Forecast sheet, you select the Show Subset ID check box in order to identify
which type of bulb the expected failure will be. You also select the Use Warranty Length check box,
enter 12 periods and click Update.

Note: By default, the software assumes an infinite warranty period. The Use Warranty Length check box allows
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you to limit the length of the warranty period. In this example, the warranty length is 12, which means that any
units  that  fail after 12 months of operation are not counted  in  the  returns as  they are assumed  to be out of
warranty.



5.1  Warranty Data Analysis

The following Forecast sheet shows the results of your analysis, with the Show Subset ID and Use
Warranty Length options selected.

The columns represent the warranty returns periods and the rows represent the sales periods. The results
indicate, for example, that you would expect to see a total of 616 bulb failures in the 19th month (column
19), and that 32 of those failures will be from bulb A (as shown in rows 13 to 15), while the remaining
failures will be from bulb B. The rest of the forecast can be read in a similar manner.

As a side analysis, you want check whether the assumption of a usage rate of 50 hours/month is valid. The
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data from the in-house test of bulb B are in terms of hours, so you first convert the data for bulb B
according to the hour-to-month ratio (by dividing the failure and suspension times by 50).

You create a new Weibull++ standard folio and manually enter the converted data. You analyze the data
sheet using the same analysis settings that were used on the in-house test data (i.e., 2P-Weibull and RRX).



5  Warranty Analysis

The following data sheet (“Bulb B - In-House Data - Months” in sample project) shows the result of the
analysis (for reference, the subset ID column shows the failure times in terms of hours).

You can now compare the results from the warranty analysis to the results from the in-house test and
verify the assumption of the usage rate. One way to do this is to display the contour plot of both data sets
and analyses on the same plot. To do this, you create an overlay plot (“Bulb B - In-House Data - Months”
and “Warranty - Bulbs” in the sample project) by choosing Insert > Reports and Plots > Overlay Plot.

When prompted to select which data sets to plot, you select the converted data set from the in-house test
and the data set from the warranty analysis of bulb B. 
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On the control panel of the plot sheet, you switch the plot type to a Contour Plot. When prompted to
specify the contour lines, you select the 2nd Level, 90% and the 5th Level 75% check boxes.

The following overlay plot (“Bulb B - Warranty vs. In-House” in sample project) shows that all the
contours overlap; therefore, the two data sets do not show a statistically significant difference in the life,
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and the 50 hour/month assumption is valid. (This assumes that the only factor is the hour-to-month ratio
and that there is no differentiation between the test and use conditions.)
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Deciding on a reliability goal/target involves trade-offs. This is because
higher reliability typically correlates with higher production costs, lower
warranty costs and higher market share. With Weibull++’s Target Reliability
tool, you can generate plots that help you visualize and estimate a target
reliability that will minimize cost, maximize profit and/or maximize your
return on an investment in improving the product’s reliability.

In this chapter, you will use cost factors to estimate the target reliability for a
product and calculate the return on an investment intended to reach that
reliability.

6.1  Reliability and Return on Investment

Based on their benchmarking and market research, the marketing group believes the company will
become the market share leader if it offers a highly reliable projector coupled with a one-year warranty
period. Specifically, their research shows that if the company maintained the current sale price of $1,500
per unit, used a one-year (600 hours) warranty and managed to provide a projector with a 99% reliability

Target Reliability 
Estimation 6

 Estimating target 
reliability

 Calculating the 
return on an 
investment in 
reliability

Watch a video of this example at 
http://www.ReliaSoft.tv/weibull/startguide/weibull_qsg_6.html.
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over the warranty period, its current 20% market share would increase to 45%. On the other hand, a highly
unreliable product (more than 50% returns under warranty) would virtually eliminate the company’s
market share (i.e., reduce it to about 1%).

The projector bulb is covered under the warranty and is the projector’s primary cause of failure. Based on
the prior in-house analyses of bulb A and bulb B (see Chapter 2 and Chapter 4), if the company were to
use bulb A, it is expected that 12% of the projectors would fail during the warranty period. Furthermore, if
the company decided to use the lower priced bulb, bulb B, it is expected that 67% of the projectors would
fail under warranty. Moreover, after looking at additional manufacturers, you learn that more reliable
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bulbs are available, but at a higher cost. You identify one manufacturer that offers a highly reliable bulb
(1% failures during the warranty period).

The cost of producing a projector without a bulb is $400. The additional cost for the bulb varies depending
on which bulb is used.

 The least expensive bulb (bulb B): $50 each.

 The moderately reliable bulb (bulb A): $175 each.

 The bulb with the highest reliability: $450 each.

Finally, each warranty claim costs $200 to process, in addition to the replacement cost of the bulb, and the
maximum market potential is estimated to be 120,000.

Objectives

 Estimate the target reliability for the projector bulb based on the one-year warranty period.

 Assume that a redesign is required to achieve the target reliability and that such a redesign effort is
estimated to require an initial investment of $10 million. Estimate the return on this investment.

Solution

To open the Target Reliability tool (“Bulb B - Target Reliability” in sample project), you choose Insert >
Tools > Target Reliability. 

In the Target Estimation Inputs area, you use the information given above to describe the following
three scenarios, all of which assume a one-year warranty:

 Best Case: Purchase the most expensive, most reliable bulb.

 Mostly Likely: Purchase bulb A, the modestly reliable bulb.
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 Worst Case: Purchase bulb B, the least expensive and least reliable bulb. 
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The following picture shows your inputs:

Here is a more detailed breakdown of the inputs:

 Expected failures/returns per period (as % of sales): With the most expensive bulb, 1% of the
projectors would be returned during the warranty period. With bulb A, 12% of the projectors would
be returned. With bulb B, 67% would be returned.

 % of market share you expect to capture: Your market share in the projector market is 20% with
bulb A. This could be increased to 45% with the most reliable bulb or reduced to 1% with bulb B.

 Average unit sales price: The sales price of the projector will be fixed at $1,500, regardless of the
type of bulb used.

 Average cost per unit to produce: Each projector costs $400 to produce, plus $450 for the most
expensive bulb, $175 for bulb A and $50 for bulb B.

 Other costs per failure: Additional costs are assumed to be fixed at $200, regardless of which
bulb is used.

Finally, to specify the maximum market potential, you enter 120,000 in the Max. Market Potential
(Units) field on the control panel.

As reliability increases, your production costs will increase, but your unreliability cost will decrease. The
Cost vs. Reliability plot allows you to visualize the relationship between reliability and cost, as well as
estimate the reliability that minimizes total cost (i.e., production cost + cost due to unreliability). After
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you enter all the inputs specified above, you click the Cost vs. Reliability in the Plot Setting area and
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click the Redraw Plot icon on the control panel. The plot appears as shown next (with annotations added
via RS Draw to make the plot easier to interpret).

As the legend in this plot shows, the reliability that is estimated to minimize cost is 96.7% at the end of the
warranty period.

Next, you select to view the R3OI vs. Reliability plot so you can estimate the reliability target that has the
highest ROI using ReliaSoft’s Reliability Return on Investment (R3OI) equation. 

According to the legend of this plot, if your goal is to maximize the return on investment, then your target
reliability should be about 96.6% at the end of the warranty period (which is obviously very close to the
96.7% reliability needed to maximize cost). With this reliability for maximizing ROI, you can expect
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3.4% of the units sold to be returned under warranty.
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Lastly, you wish to determine the return on a $10 million investment to reach the target reliability. So you
enter 10,000,000 in the Initial Investment field and click the Redraw Plot icon. After the plot refreshes,
you point to the vertical green line to display the expected return on investment at the target reliability.

This calculation indicates that the return rate on a $10 million reliability investment would be about
276.7%
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Generally, the reliability of a product is calculated based on its ability to
perform without failure for a specified period of time. In some cases,
however, you may need to obtain the reliability of a product based on its
ability to withstand an applied stress without failure, rather than the length
of time it continues to operate. An example is a wooden beam that may
buckle under a load that is over a certain weight limit. In this chapter, you
will estimate the reliability of a product based on the strength of the material
and the stress it will experience.

7.1  Stress‐Strength Analysis

A different design group in the company needs your assistance in selecting and qualifying a steel
component for a new product. Their main concern is the ability of the component to withstand the tensile
stresses in its intended application. The estimated median (50th percentile) tensile stress is 75
megapascals (Mpa). The worst case load (defined as the 99th percentile case) is estimated to be 150 Mpa.
The reliability requirement for the component is a probability of failure of 1 in 100,000 due to tensile
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Watch a video of this example at 
http://www.ReliaSoft.tv/weibull/startguide/weibull_qsg_7.html.
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loads (or a reliability of 99.999%).

The group had previously conducted a test on six specimens. They send you the following data set, which
shows the stress values at which each of the specimens failed: 212, 236, 248, 254, 271 and 287 Mpa. They
have 10 more specimens available for testing if the current information is not sufficient to demonstrate the
reliability target.
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Objectives

 Determine whether it is possible to demonstrate the required reliability with the information
provided.

 If not, design a test for 10 specimens that will demonstrate that the component meets the required
reliability if all specimens pass the test.

Solution

The first step is to obtain a distribution for the tensile stress that the component will experience in the
field. To do this, you create a Weibull++ standard folio (“Steel Component Data” in the sample project)
by choosing Insert > Folios > Weibull++ Standard Folio.

When prompted to specify the data type, you select Free-form (Probit) data.  

Once the folio is created, you double-click the name of the data sheet (located at the bottom of the
window) and rename “Data1” to “Stress.” You then enter the estimates for the tensile stress in the data
sheet. On the control panel, you choose the following analysis settings:

 2P-Weibull

 Rank Regression on X (RRX)

Note: Because the data set you are analyzing is in terms of stress rather than time, you have two choices. You can

set  the units  for  the data  sheet  to  “Hours” and  then  remember  throughout  the analysis  that any  inputs and
results given in “Hours” really means Mpa. Alternatively, if you have administrative permissions in the Synthesis
repository  (File > Manage Repository > Manage Units), you can define a new unit  for Mpa  that will  then be
available  in  the Units drop‐down  list  for any analysis performed within  the database. For  the purposes of  this
analysis,  it  is not necessary  for the software to be able to convert Mpa to some other unit so we will use the
simpler approach of interpreting “Hours” as “Mpa.” 
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 Standard Ranking Method (SRM)

 Median Ranks (MED)

To analyze the data set, you click the Calculate icon on the control panel.



7.1  Stress‐Strength Analysis

The following data sheet displays the result of your analysis. It shows that the stress distribution is a 2P-
Weibull distribution with beta = 2.732021 and eta = 85.767713 Mpa. 

Tip: Because you have two probability points (i.e., the unreliability is estimated to be 50% at 75 Mpa and 99% at

150 Mpa), you could also use the Quick Parameter Estimator (QPE) to obtain the parameters of the distribution.
To access the utility, choose Home > Tools > Quick Parameter Estimator (W++).

In the QPE, select the Two Unreliability Points option and the 2P‐Weibull distribution. Enter the stress values
(Mpa  entered  as  time)  and  unreliability  values  (percentile),  and  click  Calculate.  You  will  obtain  the  same
estimates for the parameters.
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The next step is to obtain the strength distribution. You create a second data sheet in the folio by right-
clicking the data sheet tab area (the area at the bottom of the window that shows the name of the data
sheets) and choosing Insert Data Sheet on the shortcut menu. This time, you select Times-to-Failure
data as the format and clear all the other options.



7  Stress‐Strength Comparison

You rename the second data sheet to “Strength,” and then enter the failure “times” from the test (i.e., the
stress value at which each specimen failed). 

On the control panel, you select the same analysis settings, and then click Calculate to analyze the data.
The following data sheet displays the result of your analysis. It shows that the strength distribution is a 2P-
Weibull with beta = 10.056225 and eta = 262.950892 Mpa.

The next step is to compare the stress and strength distributions. You open the Stress-Strength tool
(“Stress-Strength - Steel Component” in the sample project) by choosing Insert > Tools > Stress-
Strength Comparison.
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You select the “Stress” and “Strength” data sheets, and click OK. 



7.1  Stress‐Strength Analysis

The Stress-Strength tool shows the following plot.

In addition, the result on the control panel tells you that the reliability of the component is estimated to be
99.980787%. This value is close to the target reliability, but not close enough. 

You know that the design group has 10 more specimens that they could use to test against the tensile loads.
You want to use a zero-failure test (also called reliability demonstration test or RDT), which will
demonstrate that the component meets the required reliability if all specimens pass the test. To design the
test, first you need to determine how “strong” the component needs to be in order to meet a reliability
target of at least 99.999%. This means that you need to determine the parameters for the strength
distribution that, when compared against the stress distribution in the Stress-Strength tool, would result in
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the required reliability.

To find out, you click the Target Reliability Parameter Estimator icon on the control panel. 



7  Stress‐Strength Comparison

You select to estimate a new eta parameter for the strength distribution, and then you enter the target
reliability, which is 99.999%. When you click Calculate, the result tells you that in order to meet the
reliability target, the value of eta needs to be 356.417171, as shown next. 

Based on this result, you can now design a zero-failure test plan. To do this, you click Update to transfer
the new eta value to the Stress-Strength tool. You can see that in the control panel, the parameters of the
strength data set are now labeled “(Altered).”

You click the Reliability Demonstration Test icon of the strength data set, as shown next.
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This automatically creates a new RDT folio (“Test Design Folio - Steel Component” in the sample
project) and populates the test plan with the MTTF of the strength distribution that you want to be able to
demonstrate. The software also automatically populates all of the Parametric Binomial test plan inputs,



7.1  Stress‐Strength Analysis

including the company’s standard 90% confidence level for demonstration tests, so you just need to
choose the following settings in the Solve for this value area: 

 Value: Required test time 

 Sample size: 10

 Maximum number of failures: 0

In this analysis, the required test “time” is the tensile stress that the specimens must experience without
failure. You compute the results and it shows a “test time” (i.e., tensile stress) of 307.990114 Mpa, as
displayed next. 

You inform the group of your findings and show them the test plan you created. You explain that if they
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test 10 specimens at a tensile stress of 307.990114 Mpa and there are no failures, then this will
demonstrate that the component meets the required reliability with a 90% probability.





Competing failure modes analysis is a method of analyzing the reliability of
a product that has more than one cause of failure. The analysis uses the
following assumptions: a) the failure modes are independent, meaning that
the occurrence of one mode does not affect the probability of occurrence of
the other modes, b) the system will fail if any of the modes occur (i.e., series
configuration) and c) the failure rate behavior for each failure mode is
known and can be described with a life distribution and parameters.

In this chapter, you will work with a product that experiences multiple
failure modes and explore two ways to perform the analysis.

8.1  Competing Failure Modes

Based on your prior work, your reputation for reliability analysis work has reached other divisions within
the company. Another division requests your assistance on a classified project, but because you do not
have the required security clearance to access classified information, you have no specific knowledge
about the product. The only information that can be shared with you is that the product has three failure

Competing Failure Modes 
Analysis 8

 Competing failure 
modes analysis

 Batch auto run

 Reliability block 
diagrams

Watch a video of this example at 
http://www.ReliaSoft.tv/weibull/startguide/weibull_qsg_8.html.
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modes (A1, A2 and A3), and that it would fail if any one failure mode occurs.

http://www.reliasoft.tv/weibull/startguide/weibull_qsg_8.html
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Thirty identical units were tested. The failure times (in hours) for the test units, along with the failure
mode responsible for the failure, are given next.

Objectives

 Use the built-in Competing Failure Modes (CFM) analysis method in the Weibull++ standard folio
to perform the analysis and estimate the median time to failure of the product (i.e., B50 life).

 Perform the analysis again using a reliability block diagram (RBD), and estimate the B50 life again
to show that the results are the same.
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 Determine whether the product can meet a required B10 life of 350 hours. If it cannot be achieved,
determine which failure mode will need to be addressed in order to meet the requirement.



8.1  Competing Failure Modes

Solution

First, you create a new Weibull++ standard folio (“Competing Failure Modes” in the sample project) by
choosing Insert > Folios > Weibull++ Standard Folio.

When prompted to specify the data type, you select Times-to-failure data and clear all the other options
because your data set only contains complete data. You also use the Units drop-down list to indicate that
the time values in the data sheet will be entered in hours.

Once the folio is created, you enter the failure times and the associated subset IDs that identify the failure
modes. On the control panel, you choose Competing Failure Modes > CFM-Weibull.

The Settings area of the control panel provides a quick summary of the analysis settings that will be used
to fit the distribution. The current settings on the Main page of the control panel are as follows:

 Rank Regression on X (RRX)

 Standard Ranking Method (SRM)

 Median Ranks (MED)

 Fisher Matrix Confidence Bounds (FM)

Next, you analyze the data (fit the selected distribution to each failure mode) by clicking the Calculate
icon on the control panel.

When you select to use CFM analysis, the software prompts you to define up to four failure modes for the

Tip: These options can be set from the Analysis page of the control panel or by clicking the blue text labels in the

Settings area on the Main page.
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analysis. Each “mode” can be associated with one or more of the subset IDs of the data sheet. You move



8  Competing Failure Modes Analysis

each subset ID (on the left) under a different mode (on the right). When you are finished, the window
looks like the picture shown next.

You click OK to begin the analysis. When the data set has been analyzed, the Analysis Summary area of
the control panel displays the estimated parameters of the failure distribution for one mode at a time. 

You view the parameters of each mode by choosing the mode from the drop-down list, as shown next.

Next, you open the QCP by clicking the icon on the control panel.

To calculate the B50 life, you select BX% Life and use the Units drop-down list to make sure that the
results will be returned in hours. You enter 50 for the BX% Life At input and click Calculate. 
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8.1  Competing Failure Modes

The result will appear, as shown next.

A B50 life of approximately 561 hours means that 50% of the population will have failed by 561 hours of
operation.

Because some members of the design team are not familiar with the built-in CFM analysis method
available in Weibull++ standard folios, your next step is to perform the analysis again using the more
familiar RBD approach to demonstrate that both methods return identical results when all of the settings
and assumptions are the same.

Before you create a diagram, you need to segregate the data sets of the failure modes so that each mode
can be represented by a single block in the diagram. You click the Batch Auto Run icon on the Main page
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of the control panel.

When prompted to select the subset IDs, you select them all.



8  Competing Failure Modes Analysis

You click the Processing Preferences tab. In the Extraction Options area, you select the option shown
next.

This option allows you to extract the data sets that are required for the CFM analysis. For example, when
you extract the data points of mode A1, the Batch Auto Run utility will retain all the data points due to
mode A1 as failures but mark all other data points due to modes A2 and A3 as suspensions. They are
suspensions because the units in the sample would have continued to operate for some unknown amount
of time if they had not been removed from the test when they failed due to those modes.

In the Calculation Options area, you select to calculate the parameters of each data set based on the
selected distribution, which is the 2P-Weibull for this analysis. When you click OK, the data sets are
extracted to separate data sheets in the folio and automatically calculated.
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To create a diagram (“Competing Failure Modes - RBD” in the sample project) that allows you to analyze
the extracted data sets in a series configuration, you choose Insert > Tools > Diagram.

Once the diagram is created, you add a block by right-clicking the diagram and choosing Add Block on
the shortcut menu. When prompted to select the data sheet of the failure mode that the block will
represent, you select the data sheet for mode A1. You use the same approach to add the blocks that will
represent failure modes A2 and A3.



8.1  Competing Failure Modes

Next, you connect the blocks in an appropriate configuration to describe the relationships between the
failure modes. You add a connector by right-clicking the diagram sheet and choosing Connect Blocks on
the shortcut menu. You click the source block, hold down the left mouse button and then drag a line from
the source block to the destination block. When the crosshairs are located above the destination block, you
release the mouse button to create a connector.

The following diagram shows the modes connected in a series configuration. This indicates that the
product will fail if any of the modes occurs.

To analyze the diagram and calculate the product’s overall reliability, you click the Calculate icon on the
diagram’s control panel.

To estimate the B50 life of the product, you use the QCP. The result is about 561 hours, which is identical
to the result you obtained when you performed the CFM-Weibull analysis in the Weibull++ standard folio.

Tip: The RBD approach can also be used for more complex analyses that are not supported by the CFM analysis

methods built  into  the Weibull++ standard  folio. Specifically, you will need  to use  the RBD approach  if: a)  the
analysis involves more than four failure modes, b) the failure modes are described by different  life distribution
and/or c) the relationships between the modes do not follow a series configuration.
Weibull++/ALTA Quick Start Guide 83

You return to the CFM-Weibull analysis in the Weibull++ standard folio (“Competing Failure Modes” in
the sample project), and use the QCP to calculate the B10 life of the product.



8  Competing Failure Modes Analysis

The required B10 life is 350 hours, but the result is about 129 hours, as shown next.

To visualize how each of the failure modes contribute to the overall reliability of the product, you click the
Plot icon on the control panel. 
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8.1  Competing Failure Modes

The following probability plot shows the results (with annotations added via RS Draw to make the plot
easier to interpret).

The plot tells you that mode A2 has a strong influence on the overall probability of failure of the product.

You decide to perform a “what-if” analysis to see what the B10 life of the product would be if the failures
due to mode A2 did not occur. To do this, you create a copy of the data sheet in the folio by right-clicking
the data sheet tab area (the area at the bottom of the window that shows the name of the data sheets) and
choosing Move/Copy Sheet on the shortcut menu. You select the data sheet that contains the data set,
select the Create a Copy check box and click OK.
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8  Competing Failure Modes Analysis

Once the new data sheet is created, you rename it to “Two Modes.” You then click the Calculate icon on
the control panel to redo the CFM analysis with only two modes. When prompted to select the subset IDs,
you remove mode A2 from the list of modes, as shown next.

After performing the CFM analysis again for only modes A1 and A3, you use the QCP to calculate the
B10 life. This time, the result shows 396 hours, which indicates that the product would be likely to meet
the requirement if the designers were able to address the A2 failure mode (best case scenario).
86 Weibull++/ALTA Quick Start Guide



In life data analysis, it is assumed that the components being analyzed are
non-repairable; that is, they are either discarded or replaced upon failure.
However, for complex systems such as automobiles, computers, aircraft,
etc., it is likely that the system will be repaired (not discarded) upon failure.
Failures are recurring events in the life of a repairable system, and data from
such a system are known as recurrent event data. Weibull++ includes a
choice of two methods for analyzing recurrent event data: parametric and
non-parametric analysis. 

In this chapter, you will perform parametric recurrent event data analysis in order to estimate the number
of spare parts that will be needed to maintain a repairable system.

9.1  Parametric Recurrent Event Data Analysis (RDA)

You are performing consulting work for a customer who uses a piece of equipment that your company
manufactures. The customer has 200 such systems, with each system using five bulbs. If any one of the
bulbs in a given system fails, the system is considered failed. The customer’s maintenance department

Parametric Recurrent 
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Watch a video of this example at 
http://www.ReliaSoft.tv/weibull/startguide/weibull_qsg_9.html.
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restores the system by replacing the failed bulb. When maintenance personnel go out to repair a system,
the only information recorded is the “use time” of the system as indicated by the Hobbs meter on the
equipment. The table on the next page shows the failure logs for 28 of those systems, all recorded between
0 to 1,500 hours of operation. Each log includes the operating hours of the system at the time when each
failure occurred (indicated by an F) and the time when the observation period ended (indicated by an E). 

http://www.reliasoft.tv/weibull/startguide/weibull_qsg_9.html


9  Parametric Recurrent Event Data Analysis

Recurrent  Event  Data:  In  recurrent  event  data,  the  failure  time  that  is  recorded  is  not  the
observation  time when  the  failure  occurred, but  rather  the  age of  the  system when  the  failure
occurred. System age may be measured in terms of the number of operating hours accumulated, or
in terms of accumulated mileage, distance, etc.

1 2 3 4 5 6 7

F 467 F 543 F 826 F 326 F 322 F 796 F 197

F 792 F 755 F 978 F 571 F 548 F 829 F 624

F 1111 F 1310 F 1003 F 1016 F 641 F 952 F 909

F 1177 F 1369 F 1019 F 1025 F 648 F 1053 F 975

F 1190 F 1388 F 1162 F 1085 F 826 F 1140 F 1012

F 1333 E 1500 E 1500 F 1104 F 1087 F 1375 F 1176

F 1383 F 1119 F 1350 F 1447 F 1370

E 1500 F 1420 F 1482 E 1500 E 1500

E 1500 F 1489

E 1500

8 9 10 11 12 13 14

F 825 F 547 F 659 F 343 F 589 F 375 F 714

F 847 F 686 F 913 F 659 F 877 F 413 F 794

F 939 F 820 F 916 F 806 F 912 F 912 F 977

F 995 F 825 F 1309 F 810 F 1051 F 1032 F 1237

F 1209 F 1276 F 1319 F 936 F 1218 F 1182 F 1279

E 1500 F 1368 E 1500 F 1111 F 1343 F 1287 F 1453

E 1500 F 1262 E 1500 E 1500 E 1500

E 1500

15 16 17 18 19 20 21

F 449 F 370 F 614 F 421 F 564 F 627 F 141
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F 582 F 531 F 784 F 721 F 1195 F 734 F 545

F 898 F 547 F 921 F 1169 F 1370 F 971 F 804

F 1101 F 1045 F 1100 F 1212 F 1420 F 978 F 967

F 1154 F 1052 F 1298 F 1279 E 1500 F 1395 F 1096

F 1334 F 1077 F 1475 F 1489 F 1401 F 1154

E 1500 F 1283 E 1500 E 1500 E 1500 F 1199

F 1394 E 1500

F 1452

E 1500



9.1  Parametric Recurrent Event Data Analysis (RDA)

Objectives

 Estimate the number of bulbs that are expected to fail per system over the next 100 hours.

 Estimate the number of spare parts that the maintenance department will need to cover repairs for
all 28 systems in the next 100 hours of operation.

Solution

For this data set, you know that you cannot use life data analysis (e.g., fit a Weibull distribution to the data
set) because the failure times of each system are dependent on that system’s history of repairs. In other
words, all you know is that when a system failed, one of its five bulbs was replaced, but you do not know
which one.

In this case, from a system perspective, you are dealing with a repairable system (with the repair being the
replacement of one of the five bulbs). Each time a system is repaired, the system is returned to service, but
it is no longer in an as good-as-new condition nor as bad-as-old, but at some stage in between. To analyze
the data and answer the questions of interest to the customer, you will perform parametric recurrent event
data analysis using the general renewal process (GRP) model.

First, you create a new Parametric RDA folio (“Hobbs Readings Data” in the sample project) by

22 23 24 25 26 27 28

F 616 F 657 F 310 F 415 F 578 F 832 F 156

F 791 F 717 F 726 F 559 F 816 F 917 F 505

F 792 F 762 F 868 F 847 F 874 F 1024 F 717

F 923 F 909 F 1009 F 982 F 1082 F 1048 F 764

F 1413 F 1041 F 1017 F 986 F 1148 F 1463 F 855

E 1500 F 1277 F 1292 F 1378 F 1434 E 1500 F 903

F 1444 F 1310 E 1500 F 1483 F 1299

E 1500 E 1500 E 1500 F 1371

F 1493

E 1500
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choosing Insert > Folios > Parametric RDA.

Once the folio is created, you enter the data from the table on page 88 in the data sheet.



9  Parametric Recurrent Event Data Analysis

After entering the data, the next step is to select the settings that will be used to fit the GRP model to the
data. On the control panel, you select 3 parameters and the Type II virtual age model.

The setting for virtual age is also available on the Analysis page of the control panel, which can be
accessed by clicking the Analysis button, as shown next.

Virtual Age: The general renewal process model uses the concept of virtual age to mathematically
capture the effect of the repairs on the subsequent rate of occurrence of failure. The Type I model
assumes that the repairs will remove some portion of the damage that has accumulated since the
last repair, while the Type II model assumes that the repairs will remove a portion of all the damage
that has accumulated since the system was new. 
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On the Analysis page, you make sure that the Use Eta and RF parameterization check box is selected.



9.1  Parametric Recurrent Event Data Analysis (RDA)

To fit the general renewal process (GRP) model to the data set, you click the Calculate icon on the Main
page of the control panel.

Once the model is fitted, the Analysis Summary area of the control panel displays the parameters of the
GRP model (beta, eta and RF) as well as the LK Value. The results are shown next.

To solve for the number of bulbs that are expected to fail, you open the QCP by clicking the icon on the
control panel.

To calculate the number of bulbs that are expected to fail per system over the next 100 hours, you select
Cum. Number of Failures and use the Units drop-down list to make sure that the results will be returned
in hours. You enter 1,500 for the Mission Start Time, and 100 for the Mission Additional Time. 

Restoration  Factor  (RF):  The  RF  parameter  provides  an  indication  of  the  effectiveness  of  the
repairs as reflected by the data set. An RF = 1  indicates that the system will be “as good as new”
after the repair. This  is known as a perfect repair. An RF value between 0 and 1  indicates that the
system will be “better than old but worse than new” after the repair. This is known as an imperfect
repair. An RF = 0 indicates that the system will be “as bad as old” (i.e., no improvement) after the
repair. This is known as a minimal repair.
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The calculated result shows that 0.696 or about 1 bulb per system will fail in the next 100 hours, as shown
next.

To estimate the number of spare parts that the customer would need to repair all 28 systems in the next 100
hours, you select Failures by System and enter 100 for the Mission Additional Time. This calculates the
number of failures from the time when the observation period for the system ended (which is 1,500 hours
as indicated by an E in the folio data sheet).

You click Calculate to open the Results window that shows a detailed report on the number of failures per
system. The result indicates that there will be a total of about 20 failures in the next 100 hours. Therefore,
the customer will need 20 spare parts.
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9.1  Parametric Recurrent Event Data Analysis (RDA)

The Results window is shown next.
Weibull++/ALTA Quick Start Guide 93





Event logs, or maintenance logs, capture information about a piece of
equipment's failures and repairs, such as the date/time the equipment failed
and the date/time the equipment was restored. This information is useful for
helping companies achieve productivity goals by giving insight about the
failure modes, frequency of outages, repair duration, uptime/downtime and
availability of the equipment.

In this chapter, you will learn how to use Weibull++’s event log folio to convert maintenance logs into
times-to-failure data, and then perform basic life data analysis.

10.1  Event Log Data

While working with the manufacturing division of your company, you are given the task of analyzing the
failure behavior of a critical piece of equipment that operates for 24 hours a day, 7 days a week. The
equipment has five different subsystems (subsystems 1, 2, 3, 4 and 5). Furthermore, you learn that:

 When any one of the subsystems fails, the equipment stops operating until the failed subsystem is

Event Log Data Analysis 10
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Watch a video of this example at 
http://www.ReliaSoft.tv/weibull/startguide/weibull_qsg_10.html.
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repaired (thus the remaining subsystems do not age and cannot fail during the repair action).

 A repair action involves replacing the failed subsystem with a new (similar) subsystem.

 An automated data logger automatically captures the equipment failure events and the subsystem
responsible for the failure, as well as the date and time when the equipment was restored to
operating condition. 

 The equipment started operating on January 2, 2013 at 1:00 AM. The log was downloaded on
September 16, 2018 at 8:00 PM. 

http://www.reliasoft.tv/weibull/startguide/weibull_qsg_10.html


10  Event Log Data Analysis

Objectives

 Obtain the times-to-failure and times-to-repair distributions of each subsystem.

 Use overlay plots to compare the failure behaviors and the repair behaviors of the subsystems.

Solution

To obtain the failure distribution and repair distribution of each subsystem, you will use the event log folio
to analyze the information downloaded from the data logger.

To create a new event log folio (“Auto Data Event Log” in the sample project), you choose Insert >
Folios > Event Log.

Once the folio is created, the next step is to configure the data sheet. First, you click the Other page icon
on the control panel, as shown next. 
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In the Time to Failure/Repair In area, you select Hours so that when the software converts the
maintenance logs to failure and repair data, the unit of time will be hours.



10.1  Event Log Data

Because all of the subsystems will stop accumulating age if the equipment fails for any reason, you clear
the Use OTSF column check box. If this check box were selected, the OTSF (operates through system
failures) column would be displayed in the data sheet and you would have the option to specify which
subsystem(s) will continue to accumulate age when the system is down due to the failure of another
subsystem.

You are analyzing only one piece of equipment, so you also clear the Use System column check box. If
this check box were selected, the System column would be displayed in the data sheet and you would have
the option to enter events for multiple systems.

Next, you click the Analysis page icon, as shown next.

For both the failure and repair distributions, you select the Prefer RRX if sufficient data option and the
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2P-Weibull distribution. These will be the settings that the software will use to automatically analyze the
failure and repair data that are extracted from the event log.



10  Event Log Data Analysis

Next, you enter the information from the data logger into the data sheet, as shown next.

Event Log Data Entry:  In the event  log folio, the “F=Failure/E=Event” column  indicates whether
the occurrence was a failure event (F) or a general event (E). A general event represents an activity
that brings the system down but is not directly relevant to the reliability of the equipment, such as
preventive maintenance, routine inspections and the like.

The  Level  1,  2,  3  and  4  columns  allow  you  to  indicate  the  subsystem  or  component  that was
responsible  for  the event.  The  level numbers  represent  the hierarchy of  the  subsystems, where
Level 1  is  the highest  level  in  the  system configuration at which you might want  to perform  the
analysis.
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10.1  Event Log Data

Once data entry is complete, you click the Main page icon on the control panel, as shown next.

In the Levels to Analyze area, you select the Level 1 check box because only one level was recorded in
the data set.

In the Analyze Failures and Events area, you select the Separately option. This setting tells the software
to fit a separate distribution to the E events (if any), instead of combining both types of events together in
the same analysis. Because this data set contains only failure events (F), this setting will not affect the
analysis results, but it will provide more appropriate labeling for the extracted life data (i.e., will show [F]
for failures instead of [C] for combined events).

In the System area, you enter the dates/times when the observation period started and ended. For the start
date/time, you enter January 2, 2013 at 1:00 AM. For the end date/time, you enter September 16, 2018
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at 8:00 PM.



10  Event Log Data Analysis

Because the start date/time is also the exact calendar date that the equipment started operating, you select
the System is new on start date check box. 

To specify the shift schedule of the equipment, you click the Shift Pattern icon on the control panel.

The equipment operates for 24 hours a day, 7 days a week, so you set up the shift schedule as shown next.

Once the settings are finalized, you analyze the data (i.e., convert the logs into failure and repair data, and
fit distributions to the data sets) by clicking the Calculate icon on the control panel.

System is New on Start Date: The dates/times that you provide in the System area of the control
panel are used to determine whether the first event time is recorded as complete or censored data.
If  the  system  started operating on  the  same  calendar date  as  the  start date of  the observation
period  (i.e.,  If  the  system  was  new  when  you  started  recording  data),  then  the  data  point  is
complete (F) because the exact time‐to‐event  is known. If the system was not new, then the data
point is censored (S) because you don't know the amount of time that the system operated before
the observation period began.

Shift Schedules:  In  the  case of equipment  that does not  run on a 24/7 basis,  the Shift Pattern
feature allows the analysis to take  into consideration the periods when your system  is not  in use.
This ensures accurate calculations for the failure and repair times.
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10.1  Event Log Data

After the folio is calculated, you click the Show Analysis Summary (...) button on the Main page of the
control panel, as shown next.

The following report shows the parameters of the failure and repair distributions for each subsystem, as
well as the calculated uptime and downtime of each subsystem.

To compare the probability plots for all subsystems, you transfer the data from the event log folio to a
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Weibull++ standard folio (“Event Log - Extracted Data” in the sample project) by choosing
Event Log > Transfer Life Data > Transfer Life Data to New Folio.

This creates a new folio that contains separate data sheets for the failure and repair data of each
subsystem.



10  Event Log Data Analysis

You then calculate each data sheet using the 2P-Weibull distribution and the RRX parameter estimation
method. The following data sheet shows the analysis of the failure data for subsystem 1.

Tip: In the data sheet names, the [F] tag indicates an analysis of the failures, while [E] is an analysis of the general

events (note that a combined analysis would display [C]). The [FD] tag indicates that the data set is for the failure
distribution, while [RD] is the data set for the repair distribution.
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10.1  Event Log Data

Once all the data sets are calculated, you create an overlay plot by choosing Insert > Report and Plots >
Overlay Plot.

When prompted to select which data sets to plot, you select all the data sheets that contain the failure data
of the subsystems (i.e., all the data sheets that have the [FD] tag). The following overlay plot
(“Event Log - Failures” in the sample project) shows the failure distributions plotted on the same Weibull
probability plot.
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10  Event Log Data Analysis

You then create a second overlay plot (“Event Log - Repairs” in the sample project) that displays all the
repair distributions on the same plot (i.e., all the data sheets that have the [RD] tag). The following overlay
plot shows the repair distributions plotted on the same Weibull probability plot.
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ReliaSoft’s ALTA software provides a comprehensive toolset for accelerated
life test planning and quantitative accelerated life testing data analysis, plots
and reporting. In this chapter, you will use the ALTA standard folio to
perform the simplest kind of accelerated life testing data analysis. One
accelerated stress will be applied during the test, and you will extrapolate
the product's failure behavior at normal conditions from the life data
obtained at the accelerated levels.

After the failure times are fitted to an ALTA model (i.e., a life-stress
relationship combined with a lifetime distribution), you will use the model
to calculate a variety of reliability metrics (i.e., mean time to failure, B2 life and acceleration factor) and
create an overlay plot to compare a product that was tested at the use stress level to a product that was
tested at accelerated levels.

11.1  Accelerated Life Testing Data Analysis ‐ One Stress Type

While your company was evaluating bulb A (see Chapter 2), the purchasing group found a new supplier

ALTA with One Stress 11
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that provides a less expensive bulb C. The new supplier claims that the bulb is more reliable, and to
support this claim, they have provided data from an accelerated life test using increased temperature.
According to the supplier, the tests were done at 40 and 55 degrees Celsius (i.e., 313 and 328 kelvins) and
resulted in the failure/suspension times shown in the following table.
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11  ALTA with One Stress

You are asked to use this data set to compare bulb C to bulb A, assuming a normal operating temperature
of 25 degrees Celsius (i.e., 298 K).

Objectives

 Calculate the mean time to failure and B2 life of the new supplier’s bulb.

State (F=Failed and 
S=Suspended)

Time (Hr) Temperature (K)

F 105 313

F 170 313

F 224 313

F 278 313

S 350 313

S 350 313

S 350 313

F 38 328

F 62 328

F 82 328

F 103 328

F 128 328

F 165 328
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 Estimate the acceleration factor at 313 K.

 Generate an overlay plot that compares the unreliability vs. time for bulb A and bulb C.

Solution

You start by choosing Insert > Folios > ALTA Standard Folio to create a new folio (“Bulb C - Supplier
Data” in the sample project). 



11.1  Accelerated Life Testing Data Analysis ‐ One Stress Type

When prompted to specify the data type, you select My data set contains suspensions. You also use the
Units drop-down list to indicate that the time values in the data sheet will be entered in hours, as shown
next.

You click Next. On the second page of the setup window, you select Temperature as the stress type and
enter 298 for the use level temperature. The setup is shown next.
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11  ALTA with One Stress

After the folio is created, you enter the failure/suspension times and the stress levels at which those times
were obtained. 

For example, rows 5 through 7 in the data sheet shown next are units that were still operating after 350
hours at a test temperature of 313 K, while row 13 shows the last failure recorded at 165 hours for the
units tested at 328 K.

An ALTA model is a combination of a life-stress relationship and life distribution. From the Model drop-
down list, you select to use the Inverse Power Law relationship because the failure mode under

Tip: Temperature values must always be entered in absolute units (e.g., kelvins or degrees Rankine). To convert

temperature values in the data sheet that were entered in Celsius or Fahrenheit to absolute units, choose ALTA >
Options > Convert Stress Values.
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consideration is filament burnout. In the submenu that appears, you select IPL-Weibull to use the Weibull
distribution with the selected relationship.

To fit the selected model to the data, you click the Calculate icon on the control panel.



11.1  Accelerated Life Testing Data Analysis ‐ One Stress Type

Once the model is fitted, the Analysis Summary area of the control panel displays its parameters and
other relevant information, as shown next.

To create a probability plot to visualize the analysis results, you click the Plot icon on the control panel.

On the control panel of the plot sheet, you choose the Probability - Weibull plot, as shown next (with
annotations added via RS Draw to make the plot easier to interpret).
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The line to the left on this plot shows the unreliability calculated for the data obtained at 328 K. The line in
the center shows the unreliability at 313 K, and the line to the right shows the extrapolated unreliability at
the specified use stress level (i.e., 298 K).



11  ALTA with One Stress

To calculate the specific results of interest, you open the Quick Calculation Pad (QCP) by clicking the
icon on the control panel.

You select to calculate the Mean Life and use the Units drop-down list to make sure the results will be
returned in hours. You also make sure that the correct stress is defined in the Stress field. The results
appear as shown next.

Bulb C’s mean life is approximately 1,122 hours, which is higher than the 906-hour mean life you
calculated for bulb A. See page 10 in Chapter 2.

You use the QCP to solve the remaining metrics:
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 To estimate the B2 life of bulb C, you select to calculate BX% Life and enter 2 for the BX% Life
At input. The result is approximately 229 hours, which is lower than the 377-hour B2 life of bulb
A. See page 10 in Chapter 2.

 To estimate the ratio between the life of the bulb at an accelerated stress level to its life at the
normal stress level, you select to calculate the Acceleration Factor. In the Stress field, you enter
298, while in the Accelerated Stress field, you enter 313. The result is an acceleration factor of
3.539260 or about 3.5. This means that bulb C’s life is about 3.5 times longer at the use stress level
than it is at a higher stress level of 313 K.



11.1  Accelerated Life Testing Data Analysis ‐ One Stress Type

Finally, to compare the unreliability vs. time for bulb A and bulb C, you create an overlay plot (“Bulb A
vs. Bulb C” in the example project) by choosing Insert > Reports and Plots > Overlay Plot.

In the Select Data Sheets window, you select the Weibull++ data sheet with the combined data for bulb A
and the ALTA data sheet with the supplier data for bulb C (“Bulb A - Combined Data” and “Bulb C -
Supplier Data” in the sample project). 

In the overlay plot, you switch the plot type to a Use Level Probability Weibull, as shown next (with
annotations added via RS Draw to make the plot easier to interpret).

As you can see, the slopes of the two lines are different, and they intersect near the middle of the plot. This
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shows that at earlier times bulb A has a higher reliability than bulb C, but at later times bulb C’s reliability
is higher.





In many practical applications, the life of a product is a function of two or
more variables. To support this type of analysis, ALTA PRO includes two-
stress models and multivariable models that allow you to analyze multiple
accelerating stresses. In this chapter, you will perform a test with two
accelerated stresses and use the ALTA standard folio to analyze the resulting
data.

12.1  Accelerated Life Testing Data Analysis ‐ Two Stresses

After analyzing the accelerated life test data provided by the supplier of the new bulb, you begin to
investigate further and discover that the primary cause of the bulb failures, which is filament burnout, may
be influenced by both temperature and voltage. Therefore, you request permission to perform an in-house
accelerated life test for the bulbs, which considers both stress factors.

You are allocated 40 bulbs for testing purposes and have permission to use the lab facilities for a
maximum of 400 hours (any failures after 400 hours will be suspended). After studying the design limits

ALTA with Two Stresses 12
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of the bulb, you create the following plan:

 11 bulbs will be tested at 318 K and 120 V

 10 bulbs will be tested at 318 K and 125 V

 9 bulb will be tested at 333 K and 120 V

 10 bulbs will be tested at 333 K and 125 V

http://www.reliasoft.tv/alta/startguide/alta_qsg_12.html


12  ALTA with Two Stresses

You obtain the following data from the test:

Number 
of Units

State
(F ‐ Failure/S ‐ Suspension)

State End 
Time (Hr)

Temperature
(K)

Voltage
(V)

1 F 205

318

120

1 F 256
1 F 259
1 F 296
1 F 326
1 F 352
1 F 378
4 S 400
1 F 103

333

1 F 130
1 F 148
1 F 163
1 F 176
1 F 189
1 F 202
1 F 216
1 F 232
1 F 77

318

125

1 F 97
1 F 111
1 F 122
1 F 132
1 F 142
1 F 151
1 F 162
1 F 174
1 F 192
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1 F 33

333

1 F 42
1 F 48
1 F 53
1 F 57
1 F 61
1 F 66
1 F 70
1 F 75
1 F 83



12.1  Accelerated Life Testing Data Analysis ‐ Two Stresses

Objectives

 Calculate the mean time to failure and B2 life of the bulb.

 Estimate the acceleration factor at 318 K and 125 V.

 Generate an overlay plot that compares the use level probability plots of three data sets: combined
data on bulb A, supplier data on bulb C and in-house test data on bulb C.

Solution

You start by choosing Insert > Folios > ALTA Standard Folio to create a new folio (“Bulb C - In-House
Data” in the sample project).

When prompted to specify the data type, you select the following check boxes:

 My data set contains suspensions (right-censored data)

 I want to enter data in groups
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12  ALTA with Two Stresses

You also use the Units drop-down list to indicate that the time values in the data sheet will be entered in
hours, as shown next.
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12.1  Accelerated Life Testing Data Analysis ‐ Two Stresses

You click Next. On the second page of the setup window, you select Temperature and Voltage as the
stress types. You enter 298 for the use level temperature and 120 for the use level voltage. The setup is
shown next.

Once the folio is created, you enter the data from the test into the folio data sheet, as shown next.
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12  ALTA with Two Stresses

The next step is to select the analysis settings. On the control panel, you select the General Log-Linear
model. In the submenu that appears, you select GLL-Weibull to use the Weibull distribution with the
selected model.

To specify which stress types will be considered in the analysis, you click the Select Stress Columns link.
In the Select Stress Columns window, you select the check boxes for temperature and voltage.

To specify the transformations for the GLL model, you click the Stress Transformation link. In the Stress
Transformation window, you choose the logarithmic transformation for both temperature and voltage
(because the failure mode under consideration is filament burnout), as shown next.

To fit the selected model to the data, you click the Calculate icon on the control panel.

Stress Transformation: The general  log‐linear (GLL) model  is a multivariable relationship model
that supports cases where more than two accelerated stresses need to be simultaneously analyzed.
In ALTA,  the GLL model can analyze  life as a  function of up  to 8  stress  types and,  if desired,  the
relationship may be modified  through  the use of  stress  transformations. You have  the option  to
choose one  transformation  for each  stress  type  that  is  selected  to be used  in  the  analysis.  This
allows you to modify the GLL model in terms of a life‐stress relationship that is appropriate for the
stress type. 
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12.1  Accelerated Life Testing Data Analysis ‐ Two Stresses

Once the model is fitted, the Analysis Summary area of the control panel displays its parameters and
other relevant information, as shown next.

To create a probability plot to visualize the analysis results, you click the Plot icon on the control panel.

On the control panel of the plot sheet, you choose the Probability-Weibull plot. The resulting plot shows
the lines for the accelerated stress levels and the line for the use stress level. The lines are parallel,
indicating a common beta, as shown next (with annotations added via RS Draw to make the plot easier to
interpret).
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12  ALTA with Two Stresses

To solve for the requested reliability metrics, you open the Quick Calculation Pad by clicking the QCP
icon on the control panel.

You select to calculate the Mean Life and use the Units drop-down list to make sure the results will be
returned in hours. The mean life of the bulb is estimated to be 1,131 hours, as shown next.

You use the QCP to solve the remaining metrics:

 To estimate the B2 life, you select to calculate the BX% Life and enter 2 for the BX% Life At
input. The result is about 526 hours.

 To estimate the ratio between the life of the bulb at accelerated stress levels to its life at the normal
stress level, you select to calculate the Acceleration Factor. In the Accelerated Stress field, you
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enter 318 for the temperature and 125 for the voltage, as shown next. The result is a ratio of about
8.494413. 



12.1  Accelerated Life Testing Data Analysis ‐ Two Stresses

Next, you compare the current analysis to two other analyses. You create an overlay plot (“Bulb A vs. Bulb
C (In-House and Supplier)” in the sample project) by choosing Insert > Reports and Plots > Overlay
Plot.

When prompted to select which data sets to plot, you choose the following:

 The ALTA folio data sheet containing the data set for bulb C from the in-house test. (“Bulb C - In-
House Data” in the sample project.)

 The ALTA folio data sheet containing the data set for bulb C from the supplier. (“Bulb C - Supplier
Data” in the sample project.)

 The Weibull++ folio data sheet containing the combined data set for bulb A. (“Bulb A - Combined
Data” in the sample project.)

The following overlay plot shows the analyses plotted on the same Use Level Probability Weibull plot
(with annotations added via RS Draw to make the plot easier to interpret).
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As you can see, the lines for bulb C based on the in-house test and bulb A are parallel, while the line for
bulb C based on the supplier’s data has a different slope. 



12  ALTA with Two Stresses

To show the confidence bounds, you right-click the plot sheet and select Confidence Bounds. You then
select Two-Sided bounds and enter 90 for the confidence level. The result shows that the bounds on the
supplier’s analysis are much wider compared to the bounds on the in-house analysis. 

This indicates that the results of the in-house analysis may provide more precise estimates, allowing you
to perform a better assessment of bulb C’s reliability against bulb A.
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With ALTA PRO, you can analyze data obtained from products whose stress
levels vary with time. The software allows you to define stress profiles that
describe how stress levels increase/decrease with time. When you select to
use the Cumulative Damage (CD) life-stress relationship, which takes into
account the cumulative effect of the applied stresses, the profiles you've
defined become available for use in your analysis. In this chapter, you will
perform accelerated life testing data analysis on a product with time-
dependent use stress conditions.

13.1  Time‐Dependent Stress

Thus far, your analysis of the accelerated life test data for the new bulb C has assumed a constant stress
level under normal use conditions. (See Chapter 11 and Chapter 12.) You later learn from the design team
that the actual usage conditions are more likely to vary with time. You record the actual operating
conditions of the bulb for a period of 72 hours. Specifically, you notice the following patterns:

 The temperature alternates between 290 K and 305 K every 12 hours.

ALTA with Time‐
Dependent Stress Profiles 13
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 The voltage switches between 119 V and 123 V in the following pattern:

Operating Hours Voltage

0 to 10th hour 119 V

10th to 12th hour 123 V

12th to 22nd hour 119 V

22nd to 25th hour 123 V

At 25th hour until end of observation period 123 V
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13  ALTA with Time‐Dependent Stress Profiles

Objectives

 Calculate the mean time to failure and B2 life of the bulb, when the analysis considers the time-
dependent use stress conditions.

 Use the B2 life of the bulb to estimate the acceleration factor at 318 K and 125 V. 

 Generate an overlay plot that compares the new analysis (time-dependent use stress levels) versus
the previous analysis (constant stress levels).

Solution

The first step is to create stress profiles in ALTA that reflect the time-dependent operating conditions that
the bulb will experience.

You create a stress profile (“Use Temperature” in the sample project) by choosing Insert > Tools >
ALTA Stress Profile.

Once the profile is created, you change its default name to “Use Temperature” by right-clicking the new
profile in the current project explorer and choosing Rename on the shortcut menu. This will make the
profile easier to recognize when you need to select it within the analysis.

In the data sheet of the stress profile folio, the start time for the first segment is always set to zero. The
start times for subsequent segments are calculated automatically by the software. Thus, you will enter only
the segment end times and corresponding temperature values. After entering the data, you select the

Stress Profiles: A stress profile describes how stress levels vary with time. It consists of a series of
time segments, each with a specified constant or  time‐dependent stress  level. Stress profiles are
used with the cumulative damage  life‐stress model to perform an analysis that takes  into account
time‐varying stress levels under testing and/or during normal use.
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Repeat cycle option on the control panel. This tells the software to treat the entire pattern of segments as a
repeating cycle. 



13.1  Time‐Dependent Stress

The following picture shows the completed setup.

To save your changes and validate the profile, you click the Validate Stress Profile icon on the control
panel.

To generate a plot that shows the pattern of the segments, you click the Plot icon on the control panel.

The following plot shows the stress profile for temperature (with the scaling adjusted to Y = 0 to 400 and
X = 0 to 100). It illustrates how the normal usage temperature varies with time.
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13  ALTA with Time‐Dependent Stress Profiles

Next, you create a second stress profile for voltage (“Use Voltage” in the sample project) and rename it to
“Use Voltage.”

In the data sheet of the new stress profile, you enter the segment end times and corresponding voltage
values. After entering the data, you select the Continue from last stress option on the control panel. This
tells the software that all the times after the last segment will use the stress value defined in the last
segment. In other words, once the projector reaches 123 V for the second time, it stays at that value for as
long as the projector continues to operate. 

The completed setup is shown next.

As before, you click the Validate Stress Profile icon on the control panel to validate the data sheet entries
and save your changes. 
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13.1  Time‐Dependent Stress

You also generate a plot to show how the normal usage voltage varies with time, as shown next (with the
scaling adjusted to Y = 0 to 150 and X = 0 to 30).

Next, you duplicate the folio that contains the in-house data for Bulb C (“Bulb C - In House Data” in the
sample project). You do this by right-clicking the folio in the current project explorer and choosing
Duplicate on the shortcut menu. Once the duplicate folio is created, you rename it to distinguish it from
the original folio (“Bulb C - In House Data - Stress Profiles” in the sample project).

For this analysis, you change the ALTA model to the cumulative damage model in order to use the time-
dependent stress profiles to analyze the data. On the control panel, you choose Cumulative Damage >
CD-Weibull. You then click the Select Stress Columns link and make sure that the check boxes for
temperature and voltage are still selected.

As with the general log-linear model in ALTA, the cumulative damage model allows you to define the
transformation that will be used for each stress type. You click the Stress Transformation link and make
sure that the transformations are still set to logarithmic for both stress types (because the failure mode
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under consideration is filament burnout).



13  ALTA with Time‐Dependent Stress Profiles

To change the constant values that were defined in the previous analysis to the time-dependent stress
profiles, you click the Set Use Stress link. In the Level window, you select the Profile check box next to
each stress and choose the corresponding stress profile from each drop-down list, as shown next.

You click the Calculate icon on the control panel to analyze the data.

To solve for the requested reliability metrics, you open the Quick Calculation Pad by clicking the QCP
icon on the control panel.

You select to calculate the Mean Life and use the Units drop-down list to make sure the results will be
returned in hours. In the Stress field, you make sure that the use stress is obtained from the stress profiles. 
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13.1  Time‐Dependent Stress

The mean life of the bulb is then estimated to be 424 hours, as shown next.

You continue using the QCP to solve the remaining metrics:

 To estimate the B2 life, you select to calculate the BX% Life. In the Stress field, you select the
Profile check box next to each stress and select the corresponding stress profile from each drop-
down list. Next, you enter 2 for the BX% Life At input. The result is about 205 hours.

 You select to calculate the Acceleration Factor.

 In the Stress field, you make sure that the Profile check box next to each stress is selected.
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 In the Accelerated Stress field, you clear the Profile check boxes because the accelerated
stress values are constant. You then enter 318 for the temperature and 125 for the voltage.

 In the Mission End Time field, you enter 205.

The result is a ratio of 7.328050. This means that bulb C’s life is about 7.33 times longer at the use
stress level than it is at higher stress levels of 318 K and 125 V. 



13  ALTA with Time‐Dependent Stress Profiles

Next, you compare the new analysis with the previous analysis. You create an overlay plot (“Bulb C - In
House Data - Stress Profiles” and “Bulb C - In House Data” in the sample project) by choosing Insert >
Reports and Plots > Overlay Plot.

When prompted to select which data sets to plot, you choose the data sheet with the time-dependent
stresses and the data sheet with the constant stresses.

On the control panel of the plot sheet, you select the Unreliability vs. Time plot. The following overlay
plot (“Time-Dependent Stress vs. Constant Stress” in the sample project) shows the result of the
assumption of a constant stress against time-dependent stress (with annotations added via RS Draw to
make the plot easier to interpret).
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If the usage conditions of the bulb vary with time, then the assumption of a constant stress over-estimates
the life of the bulb. In this case, the analysis with the time-dependent stress profiles provides a more
accurate model of the operating conditions of the bulb and, therefore, more precise estimates.



In Chapter 3, we illustrated how degradation analysis can reduce the time
required to obtain a product’s life data. To reduce testing time even further,
the degradation can be measured at accelerated stress levels. This type of
approach is known as accelerated degradation analysis. In this chapter, you
will work with degradation measurements obtained at accelerated stress
levels and use the ALTA degradation folio to estimate the product’s life
characteristics under normal stress conditions.

14.1  Accelerated Degradation Analysis

The LED lamp designers that you worked with before (Chapter 3) want to perform another test to capture
data about the degradation in the light output over time. But this time, instead of 2 months, they can
reserve the lab for only 2 weeks (336 hours) so they decide to use an accelerated test. For reference, they
give you the following information:

 The normal stress level of the lamp is 120 volts, but higher voltage levels are known to accelerate
the progression of the same failure modes that occur under normal use conditions.

Accelerated Degradation 
Analysis 14

 ALTA Degradation 
folios

 Overlay plots 

Watch a video of this example at 
http://www.ReliaSoft.tv/alta/startguide/alta_qsg_14.html.
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 The degradation of the lamp is measured in terms of how the light output decreases over time.

 The lamp is considered failed when its light output reaches 50% of its design output of 1,000
lumens.

The plan is to test 10 lamps at 128 volts and another 10 at 138 volts. The highest voltage level is expected
to accelerate the degradation in the light output without introducing “foolish failures” (i.e., failures that
would never occur under normal use conditions). The light intensity of the lamps will be recorded at 100,
150, 200 and 250 hours.

http://www.reliasoft.tv/alta/startguide/alta_qsg_14.html


14  Accelerated Degradation Analysis

You obtain the following measurements from the test.

Luminosity Measurements at 128 Volts

Luminosity Measurements at 138 Volts

Objectives

 Use a Degradation vs. Time plot to see how the luminosity of the lamps degrades over time.

 Generate an overlay plot that compares the probability plots for the accelerated degradation
analysis and the standard degradation analysis in Chapter 3.

Solution

You create an ALTA degradation folio (“Accelerated Degradation - LED Lamp” in the sample project) by
choosing Insert > Folios > ALTA Degradation.

Inspection 
Time (Hr)

Lamp 
01

Lamp 
02

Lamp 
03

Lamp 
04

Lamp 
05

Lamp 
06

Lamp 
07

Lamp 
08

Lamp 
09

Lamp 
10

100 979 969 1010 857 898 816 949 887 887 928

150 908 918 908 745 775 785 908 826 816 867

200 867 877 847 683 724 745 857 775 745 816

250 826 836 796 627 683 714 836 745 704 785

Inspection 
Time (Hr)

Lamp 
11

Lamp 
12

Lamp 
13

Lamp 
14

Lamp 
15

Lamp 
16

Lamp 
17

Lamp 
18

Lamp 
19

Lamp 
20

100 768 760 792 672 704 640 744 696 696 728

150 712 720 712 584 608 616 712 648 640 680

200 680 688 664 536 568 584 672 608 584 640

250 648 656 624 492 536 560 656 584 552 616
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14.1  Accelerated Degradation Analysis

When prompted to define the stress, you select Voltage and then enter 120 for the use stress level.

Once the folio is created, you enter the degradation measurements into the folio’s data sheet.

The next step is to specify how the failure times will be extrapolated from the luminosity measurements.
Based on your engineering knowledge, you select Power from the drop-down list in the Degradation
Model area. For the lamp’s Critical Degradation (i.e., the luminosity level at which a lamp is considered
failed), you enter 500 lumens.
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14  Accelerated Degradation Analysis

Next, you need to specify how the extrapolated failure times will be analyzed. In the ALTA Model area,
you choose Inverse Power Law > IPL-Weibull. The following picture shows the completed setup.

To analyze the data set, you click the Calculate icon.

The software will first extrapolate the times at which the degradation measurements will reach the point of
critical degradation at the accelerated levels, and then it will perform a separate accelerated life testing
data analysis on the extrapolated data.

To view a plot that shows how the luminosity for each unit in the sample degrades over time, you click the
Plot icon on the control panel and select the Degradation vs. Time (Linear) plot. The resulting plot is
134 Weibull++/ALTA Quick Start Guide



14.1  Accelerated Degradation Analysis

shown next (with the scaling adjusted to Y = 450 to 1,000 lumens). The horizontal line near the bottom of
the plot marks the luminosity level at which the lamp is considered failed.

You know that in accelerated life testing data analysis, the farther the accelerated stress level is from the
normal stress level, the greater the uncertainty in the extrapolation. To compare the results obtained from
the accelerated degradation test to the results obtained from the standard degradation test, you generate an
overlay plot (“Degradation Analysis Comparison” in the sample project) by choosing Insert > Reports
and Plots > Overlay Plot. 

When prompted to select which data sets to plot, you select the data sheet containing the ALTA
degradation analysis and the data sheet containing the Weibull++ degradation analysis (“Accelerated
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Degradation - LED Lamp” and “Degradation - LED Lamp” in the sample project).



14  Accelerated Degradation Analysis

On the control panel of the plot sheet, you switch the plot type to a Use Level Probability Weibull plot.
The following overlay plot shows the results of the two analyses on the same plot (with 90% two-sided
confidence bounds on reliability).

The overlay plot shows that the probability lines have similar slopes; however, the bounds on the
accelerated degradation analysis are much wider compared to the bounds on the standard degradation
analysis. Nevertheless, you were able to obtain reasonable results within the allotted test time.
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RELIASOFT CORPORATION END-USER LICENSE 
AGREEMENT 

 
This ReliaSoft Corporation End-User License Agreement is a legal agreement between You and ReliaSoft 
Corporation for ReliaSoft Corporation's software products, which includes computer software and associated 
media and printed materials as well as on-line or electronic documentation and any software updates or 
upgrades, henceforth collectively called the “Application.” 

By installing, copying or otherwise using the Application, You agree to be bound by the terms of this End-User 
License Agreement and represent and warrant that You are authorized to do so. If You do not agree to the 
terms of this End-User License Agreement, do not install or use the Application and promptly return the 
Application to the vendor from which you obtained it within fourteen (14) calendar days from the date of 
purchase for a full refund. 

This Agreement is effective from the earlier of the date You open the sealed software package, if applicable, or 
install the Application, or fourteen (14) calendar days from the date the Application was purchased or otherwise 
obtained from ReliaSoft Corporation, and continues until expressly terminated by ReliaSoft Corporation. 

This Application is protected by copyright laws and international copyright treaties, as well as other intellectual 
property laws and treaties. This Application is licensed, not sold. 
 

1 DEFINITIONS 
1.1 Access. Means connected to or using the Application in any manner, either directly or 

indirectly through any middle tier application or system. 

1.2 Activate. Means the act of enabling the Application to operate on a specific computer by 
registering the Application license with the ReliaSoft License Server and activating the 
Application for operation. 

1.3 Location. Means the postal address of the site where the Application shall be installed. 
Location shall mean a single physical location. 

1.4 Named User(s). Means the individual(s) permitted to Access the Application, and it refers 
to specific individuals. 

1.5 ReliaSoft License Server. Means the ReliaSoft server(s) that provides license activation, 
registered end-user management, license management and license compliance 
enforcement services for the Application.  

1.6 You. Means the licensee or the individual acquiring the license of this Application and, in 
either case, the affiliates, employees, contractors and agents of said licensee or individual. 

2 LICENSE GRANT 
2.1 Grant. Subject to the license types defined in Section 3 hereof, You are granted a personal, 

non-exclusive and limited license to install, Activate and Access the Application under the 
license type and in the quantities for which You have obtained a license. You may install 
and Activate the Application onto designated equipment at the specified Location(s), solely 
as necessary to use the Application in accordance with this Agreement. You may not 



distribute, sublicense, copy (except as expressly permitted in this Agreement), transfer 
(except as expressly permitted in this Agreement), nor give the Application to any third 
party. 

2.2 Ownership. The Application and the information it contains, including any updates, 
upgrades, modifications and derivative works, and all copies of them, are the property of 
ReliaSoft Corporation (or its licensors), and title remains with ReliaSoft Corporation (or 
ReliaSoft Corporation's licensors). All applicable rights in patents, copyrights and trade 
secrets in the Application are and will remain with ReliaSoft Corporation (or ReliaSoft 
Corporation’s licensors). No title to, or ownership of, the Application or the information 
contained therein is transferred to You. ReliaSoft Corporation reserves all rights not 
explicitly granted in this Agreement. 

2.3 Rights to Developments. This Agreement also governs your use of any enhancements, 
data, or information provided by ReliaSoft Corporation while performing any technical, 
training or consulting services. Any ideas, know-how, techniques and software developed 
by ReliaSoft Corporation, including any enhancements or modifications made to the 
Application by any person, are the property of ReliaSoft Corporation. 

3 INSTALLATION AND USE 
ReliaSoft Corporation licenses any Application under this Agreement on a per user basis. In other 
words, ReliaSoft Corporation licenses an Application to each user and not to a particular computer. 
This Agreement grants You the following rights, depending on the license You have obtained from 
ReliaSoft Corporation:  

3.1 Single User License. The Single User License is licensed to one individual Named User. 
This is a perpetual license. Each software package includes the installation media and one 
copy of the Application documentation per license, either in physical/hard copy format 
and/or electronic format. The Named User may install, Activate and Access the Application 
on up to three computers (i.e., multiple Locations), such as a work computer, a home 
computer and a portable computer, provided that the Named User is the only person who 
uses this Application, at any time, in any of these Locations. In the event that installation 
and activation of the Application is performed on three computers, the Named User will be 
required to deactivate at least one installation before being allowed to Activate the 
Application again. There is a limit of 6 activations allowed per year. The Single User 
License cannot be installed on multi-user capable environments such as Windows, 
Terminal or Citrix servers. 

Use of the Application on any of the computers by any user other than the Named User who 
has licensed the Application is strictly prohibited. Such other users must obtain a separate 
license of the Application from ReliaSoft before any use. 

3.2 Standard Network License. The Standard Network License is licensed to Named Users in 
an organization on a single network of computers at a specified Location. This is a 
perpetual license. The software package includes the installation media and one copy of the 
Application documentation per license, either in physical/hard copy format and/or electronic 
format. Note: This is not a Concurrent Network License. 



This license provides for a limited number of Named Users, dependent on the quantity of 
seats licensed, to install, Activate and Access the Application, with a single activation 
allowed for each Named User. For example, if You purchase a ten (10) seat Standard 
Network License, only ten (10) specific Named Users are allowed Access. If an eleventh 
(11th) user wishes to have Access to the Application, an additional seat must be licensed. In 
the event that installation and activation of the Application is required on a new computer for 
a Named User, the Named User will be required to deactivate the active installation before 
being allowed to install and Activate the Application on the new computer. The Standard 
Network License allows for installation on multi-user capable environments such as 
Windows, Terminal or Citrix servers. 

Under this license, no other copies can be installed on non-network computers, such as 
portable computers, home computers, etc.  

3.3 Concurrent Network License. The Concurrent Network License is licensed to an 
organization with multiple regular and occasional Named Users on a single network of 
computers at a specified Location. This is a perpetual license. The software package 
includes the installation media and one copy of the Application documentation per license, 
either in physical/hard copy format and/or electronic format. Concurrent Network Licenses 
are specified by two attributes:  

(i) Number of Named User Activations, which is the maximum number of computers on 
which a Named User can Activate the Application (i.e., make it available for operation). 
More than one activation is allowed for each Named User (e.g., to install the 
Application on both a work computer and a portable computer), but each activation is 
counted toward the maximum available under the license. 

(ii) Number of Concurrent Access Licenses (or CALs), which is the maximum number of 
computers that can Access the Application at any given time.  

For example, for a Concurrent Network License with thirty (30) Named User Activations and 
ten (10) CALs, the Application can be installed and activated on up to 30 computers (e.g., 
by 30 Named Users each activating the Application on only one computer, by 15 Named 
Users each activating the Application on two computers, etc.), and only ten (10) of those 
computers will be able to Access the Application at the same time. If a user attempts to 
Access the Application from an eleventh (11th) computer, the user must wait until one of the 
other ten users ends their session and releases the CAL. The Concurrent Network License 
allows for installation on multi-user capable environments such as Windows, Terminal or 
Citrix servers. 

Under this license, Named Users are allowed to check out a CAL from the ReliaSoft 
License Server for a specified period of time, effectively being guaranteed Access to the 
Application while simultaneously reducing the number of available CALs for the rest of the 
user pool until the CAL is checked back into the ReliaSoft License Server or otherwise 
released. This ability to check out a CAL from the ReliaSoft License Server is only available 
for Applications designated as Major Version 8 and above (e.g., 8.0.1, 8.0.2, etc).  

This type of license requires that you provide/allow internet access from the Application to 
the ReliaSoft License Server at https://Validate.ReliaSoft.org.  Concurrency authorization 



and control is managed and provided by this server. You may need to modify and adjust 
your internet and/or firewall settings and/or set the aforementioned server as a trusted 
location in order to use the Application. This requirement for connectivity to the ReliaSoft 
License Server for concurrency authorization and control only applies for Applications 
designated as Major Version 8 and above (e.g., 8.0.1, 8.0.2, etc). 

3.4 Asset-based License (only applies to Orion eAPI software). The Asset-based License is 
licensed to all direct employees of a corporate entity within one or more specified Sites, 
depending on the license obtained. This license excludes subcontractors, suppliers or 
temporary employees, unless they are using the Application inside an eligible Site on a 
computer owned by that Site. This is a perpetual license. 

 Under this license, an unlimited number of Named Users from the licensing Site or Sites is 
allowed to Access the Application; however, the license restricts the number of physical 
assets (commonly referred to as Asset TAGs) that can be configured and managed within 
the Application. For this license, a Site is defined as a distinct physical address/site of a 
corporate entity, where the physical assets being managed reside (e.g., a refinery or a mine 
or a power station). The license specifically excludes broader geographical areas, such as 
cities or states/provinces (where multiple Sites might exist). 

3.5 Unlimited User License. The Unlimited User License is licensed to all direct employees of 
a corporate entity within a specified Site, Division, or Corporation, depending on the type of 
license obtained. This license excludes subcontractors, suppliers or temporary employees, 
unless they are using the Application inside an eligible facility on a computer owned by that 
facility. This is a perpetual license. 

Site-Wide License: Covers all direct employees working at a distinct physical address/site of 
a corporate entity. A Site-Wide License specifically excludes broader geographical areas, 
such as cities or states/provinces (where multiple sites might exist). 

Division-Wide License: Covers all direct employees affiliated with a unique business unit of 
a corporate entity organized in multiple divisions/business units. Examples of divisions are 
the Aerospace Division of a large conglomerate or the Brakes Division of an automotive 
corporation. A Division-Wide license might additionally be restricted to a specific 
geographical area to facilitate licensee requirements (for example, the Aerospace Division 
of a conglomerate in North America). 

Corporate-Wide License: Covers all direct employees of a corporate entity. 

This license entitles the specified corporate entity at the specified Site/Division/Corporation 
to make and distribute copies of the Application in executable code in its entirety, as 
supplied by ReliaSoft Corporation, OR install and distribute the Application over a network. 
The software package includes the installation media and one copy of the Application 
documentation per license, either in physical/hard copy format and/or electronic format. The 
Unlimited User License allows for installation on multi-user capable environments such as 
Windows, Terminal or Citrix servers. 

3.6 Rental License. Rental licenses are available for the Single User, Standard Network and 
Concurrent Network licenses. The license terms are the same as the corresponding license 



type being rented except that the license expires according to the term purchased. The 
rental fee will not be prorated or refunded if license rental is cancelled or not used in full. A 
standard non-expiring license may be purchased at any time at the current Application list 
price. 

3.7 Evaluation, Demo, No Save Demo, Beta, or Otherwise Expiring or Non-Expiring 
Licenses of any Type Provided for Evaluation Purposes. These are Evaluation/Not for 
Sale licenses and, notwithstanding any other section of this Agreement, You may not use 
the Application for commercial purposes, nor sell or otherwise transfer it for value. 
“Commercial purposes” include the use of the Application in creation of publicly distributed 
computer software. You are acquiring only the limited right to use a single copy of the 
Application solely for evaluation purposes and for a limited time. ReliaSoft Corporation can 
terminate this Agreement at any time. You have no rights under any sections of this 
Agreement other than those specifically allowed for within this section (Section 3.7).  THE 
APPLICATION IS LICENSED AS IS with no representations or warranties of any kind. 
Note: As the section title implies, users of any license provided by ReliaSoft Corporation for 
evaluation purposes (even if it is, for example, a Single User or Network License), shall 
abide by the rules set forth in this section. 

3.8 Complimentary License. Complimentary Licenses have the same installation and use 
rights as their corresponding purchased licenses (e.g., a Complimentary Single User 
License provides the same installation and use rights as the Single User License). 
However, You have no rights under any other sections of this Agreement other than those 
specifically allowed for within this section (Section 3.8).  THE APPLICATION IS LICENSED 
AS IS with no representations or warranties of any kind and license transfers are NOT 
allowed. 

Regardless of the license type You have obtained from ReliaSoft Corporation, You may access 
shared data storage files or databases relating to the Application across a wide area network (WAN) 
or a virtual private network (VPN), instead of a local area network (LAN), as long as such access is 
permitted by your policies and authorized by You via appropriate Application and network 
configuration settings. Although such access is not prohibited by ReliaSoft Corporation, you 
acknowledge that WAN and VPN data transfer rates vary widely and could lead to decreased and 
unpredictable performance (as compared to a LAN) and therefore disclaim any expectation of 
Application performance should you choose to a) configure any part of the Application, b) use the 
Application, or c) access shared data storage files in a distributed environment over a WAN or VPN. 
Such disclaimer does not apply to any Application designated and licensed as a native Web-based 
Application by ReliaSoft Corporation. 

4 SOFTWARE TRANSFERS 

4.1 Single User License. You may permanently transfer all of your rights related to a Single 
User License under this Agreement, provided that You retain no copies, You transfer all of 
the Application (including all component parts, media, printed or electronic materials, any 
upgrades and this Agreement) and the transferee agrees to the terms of this Agreement. If 
the Application is an upgrade, any transfer must include all prior versions of the Application. 
Single User License transfers are only allowed between Named Users of the same 



organization (i.e., transfers are not allowed across different organizations). The Named 
User transferring the Application must deactivate any and all active installations of the 
Application before the transferee can Activate the Application. A Single User License may 
not be transferred more than two times in a year. This section also applies to Single User 
License Rentals. 

4.2 Standard Network, Concurrent Network, Asset-based and Unlimited User Licenses. 
Standard Network, Concurrent Network, Asset-based and Unlimited User licenses are NOT 
transferable across organizations, and licensing rights CANNOT be split or transferred 
between multiple organizations in cases of corporate acquisitions or divestitures, except as 
allowed in items (a) and (b) of this section (Section 4.2), and with ReliaSoft Corporation’s 
written consent.  

In the case of Standard and Concurrent Network Licenses, Named User Activations can be 
deactivated and replaced by new users on a permanent basis. In other words, replacement 
of users is allowed to accommodate attrition and reassignment of user responsibilities in the 
ordinary course of doing business. However, replacing users on a daily, weekly, monthly or 
even quarterly basis and frequently reactivating users that were previously replaced is an 
indication that the number of Named Users (for Standard Network Licenses) or Named 
User Activations (for Concurrent Network Licenses) obtained by You is not adequate to 
serve the pool of users intending to Access the Application and is therefore prohibited. Each 
Standard Network License seat or Concurrent Network Named User Activation can be 
reassigned to a different Named User no more than two times in a year. 

In cases of corporate acquisitions or divestitures: (a) Standard Network and Concurrent 
Network licenses remain with the organization that originally obtained the licenses, (e.g., if 
the organization that holds the license is acquired by another entity, the licensing rights will 
be transferred to the acquiring entity); (b) Unlimited Site-Wide licenses remain with the 
original licensing site and therefore pass on to the owner of the specific licensing site as 
long as the site continues to exist; (c) Unlimited Division-Wide licenses remain with the 
organization that originally obtained the licenses in cases where the Division is being 
partially divested, and are terminated when the Division is fully divested. As an example, in 
a partial divestiture, the portions of the Division divested will not have access to the 
Division-Wide license whereas the portions of the Division that remain will continue to have 
access to the Division-Wide license; and (d) Unlimited Corporate-Wide licenses remain with 
the organization that originally obtained the licenses as long as said organization divested a 
portion of its business or acquired other organizations, and are terminated in cases where 
said organization was acquired by another organization. As an example, in a partial 
divestiture, the portions of the corporation divested will not have access to the Corporate-
Wide license whereas the portions of the corporation that remain will continue to have 
access to the Corporate-Wide license. As a further example, an organization with a 
Corporate-Wide license having acquired other entities (either in part or in whole) will 
continue to have the same licensing rights as before the acquisition and can therefore 
deploy the same licensing rights to the newly acquired entities. 

This section also applies to Standard Network and Concurrent Network License Rentals.  



5 DESCRIPTION OF OTHER RIGHTS, LIMITATIONS AND MISCELLANEOUS 
ITEMS 

5.1 Limitations on Reverse Engineering, Decompilation and Disassembly. You may not 
reverse engineer, decompile or disassemble the Application. You shall not provide, disclose 
or otherwise make available the Application, in any form, to any person other than your 
employees and under your direction and control for purposes specifically related to your 
permitted use of the Application. You will not:  (a) alter, modify or prepare derivative works 
of the Application; (b) transmit the Application electronically by any means; or (c) cause or 
permit the translation, reverse engineering, disassembly, or decompilation of the Application 
to determine any design structure, source code, concepts and methodology behind the 
Application, whether to incorporate it within any product of your own creation, create a 
derivative work, create any product that is competitive with the Application or other 
ReliaSoft Corporation products, or for any other purpose. 

5.2 Copyright. All title and copyrights to the Application are owned by ReliaSoft Corporation (or 
its suppliers or licensors). The Application is protected by copyright laws and international 
treaty provisions. Therefore, You must treat the Application like any other copyrighted 
material except that You may make one copy of the media solely for backup or archival 
purposes.  

5.3 Proprietary Notices. All title, trademarks, copyrights and intellectual property rights in and 
pertaining to the Application (including but not limited to any copies thereof, software 
structure and organization, source code, images and new releases) are valuable property of 
ReliaSoft Corporation and are owned or licensed by ReliaSoft Corporation. You may not 
intentionally remove, alter or destroy any form of copyright and trademark notices, 
proprietary markings or confidential legends placed upon or contained within the 
Application, including but not limited to any such notices contained in physical and/or 
electronic media or documentation, in the Application interface boxes, or in any of the 
runtime resources, code or other embodiments originally contained in or dynamically or 
otherwise created by the Application.   

5.4 Use of ReliaSoft Corporation’s Marks. You may not use the name, logos, trade names or 
trademarks of ReliaSoft Corporation or any of its affiliates in any manner including, without 
limitation, in your advertising, promotional literature or any other material, whether in 
written, electronic, or other form distributed to any third party, except in the form provided by 
ReliaSoft Corporation and then solely for the purposes of identifying your use of the 
ReliaSoft Corporation Application.   

5.5 Verification. You will provide, on ReliaSoft Corporation’s reasonable written request, 
written verification that the Application is being used according to the terms of this 
Agreement. Upon thirty days prior written notice, if ReliaSoft Corporation has reasonable 
grounds to believe that this Agreement has been breached, ReliaSoft may audit your use of 
the Application provided such audit is: (a) limited to records relating solely to the Application 
necessary to verify compliance with the terms of this Agreement; (b) performed by a 
reputable independent third party auditor acceptable to You (acting reasonably); (c) the 
third party auditor shall comply with your standard security policies; (d) the third party 



auditor shall execute your standard protective non-disclosure agreement; and (d) the cost of 
any requested audit will be solely borne by ReliaSoft Corporation if no breach is found as a 
result of the audit or will be solely borne by You if a breach is found. Such audit shall occur 
no more than once every twelve months and shall not unreasonably interfere with your 
normal business operations.  

5.6 Modification. ReliaSoft Corporation reserves the right to modify or enhance the Application 
without obligation to notify You of such changes or to furnish them to You, unless otherwise 
agreed upon with a separate agreement (such as an annual maintenance agreement). 

5.7 Copying. You may not, under any circumstances, copy the Application, in whole or in part, 
except as expressly provided under the Copyright section above. 

5.8 Separation of Components. The Application is licensed as a single product. Its 
component parts may not be separated for use on more than one computer.   

5.9 Rental or Other Exploitation. You may not publish, sub-license, re-license, assign, sell, 
distribute, license, transfer, rent, lease or lend the Application to any party, except transfer 
the Application as expressly provided under the Transfer section above. If you received any 
revenues from the unlawful distribution of the Application, such revenues will be forfeited to 
ReliaSoft Corporation.  

5.10 Fees. You will pay ReliaSoft Corporation all fees or other amounts due under this 
Agreement, plus any and all applicable taxes, within the payment term due date specified 
on the respective invoice. In the event that the respective invoice is not paid on time, or at 
all, ReliaSoft Corporation reserves the right to terminate this Agreement and revoke the 
corresponding licenses issued to You within the scope of this Agreement. 

5.11 Termination. Without prejudice to any other rights, ReliaSoft Corporation may terminate 
this Agreement if You fail to comply with the terms and conditions of this Agreement and 
such breach is not cured within thirty days of notice of such breach. In such event, You 
must destroy all copies of the Application and all of its component parts. Additionally, You 
may be held liable for any damage or loss of profit caused to ReliaSoft Corporation arising 
from unauthorized use or duplication of this Application.   

5.12 Supplemental Licenses. If, after the effective date of this Agreement, You subsequently 
purchase additional licenses of the Application, these supplemental licenses will be 
included under this Agreement.   

5.13 Press Releases. As part of this Agreement, You acknowledge that ReliaSoft Corporation 
may make reference to You as a customer of ReliaSoft Corporation in press releases, 
advertising and promotional materials, and You consent to any such reference. ReliaSoft 
Corporation will NOT disclose any further details beyond referring to You as a customer 
without prior written consent, not to be unreasonably withheld. 

5.14 Relationship. You and ReliaSoft Corporation are independent contractors and neither is an 
agent, joint venture partner, partner or employee of the other, and ReliaSoft Corporation will 
not be obligated by any agreements or representations made by You to any person, nor 
with respect to any other action by You, nor will ReliaSoft Corporation be obligated for any 



damages to any person, whether caused by your actions, failure to act, negligence or willful 
conduct.   

5.15 Upgrades. If the Application is an upgrade from another product, whether from ReliaSoft 
Corporation or another supplier, You may use or transfer the Application only in conjunction 
with that upgraded product, unless You destroy the upgraded product. If the Application is 
an upgrade of a ReliaSoft Corporation product, You may use the upgraded product only in 
accordance with this Agreement. If the Application is an upgrade of a component of a 
package of software programs that You licensed as a single product, the Application may 
be used and transferred only as part of that single product package and may not be 
separated for use on more than one computer. 

5.16 U.S. Government Restricted Rights. The Application was developed at private expense. 
No portion of the Application was developed with government funds and the Application is a 
trade secret of ReliaSoft Corporation for all purposes of the Freedom of Information Act. 
The Application and documentation are provided with RESTRICTED RIGHTS. Use, 
duplication or disclosure by the Government is subject to restrictions as set forth in 
subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at 
DFARS 252.227-7013 (or its successor) or subparagraphs (c)(1) and (2) of the Commercial 
Computer Software Restricted Rights at 48 CFR 52.227-19 (or its successor), as 
applicable. Manufacturer is ReliaSoft Corporation, 1450 S. Eastside Loop, Tucson, Arizona 
85710, USA. 

5.17 Limited Warranty. ReliaSoft Corporation warrants that: (a) the Application will perform 
substantially in accordance with the accompanying written materials, and on machines 
meeting the published minimum requirements, for a period of sixty (60) days from the date 
of receipt; and (b) any media on which the Application is furnished will be free from defects 
for a period of sixty (60) days from the date of receipt. Some states and jurisdictions do not 
allow limitations on duration of an implied warranty, so the above limitation may not apply to 
You; in such states and jurisdictions the liability of ReliaSoft Corporation shall be limited to 
the minimum extent permitted by law. To the extent allowed by applicable law, implied 
warranties on the Application and media, if any, are limited to sixty (60) days; and (c) at the 
time of installation, the Application will be free from any mechanism, feature or any other 
codes or instructions that: (i) cause the Application to remotely transmit information to 
ReliaSoft or any third party, except to communicate with one of ReliaSoft’s servers to 
facilitate specific functions of the Application (such as to communicate with the ReliaSoft 
License Server, access the online help files, etc.); or (ii) may be used to permit Access to, 
or use of, the Application or computer system on which the Application is loaded, or to 
which the Application is linked, by ReliaSoft or any third party.  

5.18 Customer Remedies. ReliaSoft Corporation's and its suppliers' or licensors’ entire liability 
and Your exclusive remedy shall be, at ReliaSoft Corporation's option, either (a) return of 
the fee paid for the Application, or (b) repair or replacement of the Application or media that 
does not meet ReliaSoft Corporation's Limited Warranty and which is returned to ReliaSoft 
Corporation with a copy of your receipt or invoice. Any replacement Application or media 
will be warranted for the remainder of the original warranty period or thirty (30) days, 



whichever is longer. None of these remedies nor any product support services offered by 
ReliaSoft Corporation are available without a valid License Certificate issued by ReliaSoft 
Corporation.  

5.19 Warranty Exclusions. The Limited Warranty is void if the damage or defect has resulted 
from accident, abuse or misapplication. Any modification of the Application by any person 
other than ReliaSoft Corporation shall void this warranty. Any manipulation of the 
Application’s data storage infrastructure or direct storage of data into the Application’s data 
storage from outside the Application by any person other than ReliaSoft Corporation or 
ReliaSoft Corporation’s authorized representative shall void this warranty. The warranties in 
this section extend only to You and are contingent upon proper use of the Application. The 
warranties will not apply to any failure caused by (a) accident, (b) unusual physical, 
electrical or electro-magnetic stress, (c) negligence, (d) misuse, (e) failure of electrical 
power, air conditioning or humidity control, (f) use of the Application with any equipment or 
software not reflected in ReliaSoft Corporation’s specifications, (g) installation, alteration or 
repair of the Application by anyone other than ReliaSoft Corporation or ReliaSoft 
Corporation’s authorized representative, or (h) or installation on equipment on which the 
original identification marks have been removed or altered.   

5.20 No Other Warranties. No oral or written information or advice given by ReliaSoft 
Corporation, its suppliers, dealers, distributors or agents shall create a warranty or in any 
way increase the scope of the Limited Warranty, and You may not rely on any such 
information or advice as a warranty.  

5.21 Use of Results Provided By the Application Disclaimer. You understand that the results 
provided by the Application cannot replace judgment required for important decisions. Use 
of the results provided is done completely at your own risk. ReliaSoft Corporation does not 
warrant that the functions of this Application will meet your requirements or be error free. 
You assume all risk of the use, quality and performance of the Application, and You are 
advised to use your own discretion and judgment regarding the use of the Application. 

5.22 RELIASOFT CORPORATION, ON BEHALF OF ITSELF AND ITS LICENSORS, 
DISCLAIMS ALL OTHER WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING, 
BUT NOT LIMITED TO, IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS 
FOR A PARTICULAR PURPOSE, WITH REGARD TO THE APPLICATION. IN NO EVENT 
SHALL RELIASOFT CORPORATION OR ITS SUPPLIERS OR LICENSORS BE LIABLE 
FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR CONSEQUENTIAL DAMAGES 
WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF 
BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION 
OR ANY OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OF OR INABILITY TO 
USE THE APPLICATION, EVEN IF RELIASOFT CORPORATION HAS BEEN ADVISED 
OF THE POSSIBILITY OF SUCH DAMAGES. USE OF THIS APPLICATION IS DONE 
COMPLETELY AT YOUR OWN RISK, INCLUDING THE USE OF RESULTS PROVIDED 
BY THIS APPLICATION.  RELIASOFT CORPORATION’S LIABILITY HEREUNDER 
SHALL BE LIMITED TO PHYSICAL DAMAGE DIRECTLY CAUSED BY THE SOLE 
NEGLIGENCE OF RELIASOFT CORPORATION AND SHALL NOT EXCEED THE PRICE 



PAID FOR THE SOFTWARE PRODUCT. NOTWITHSTANDING ANYTHING HEREIN TO 
THE CONTRARY, THE FOREGOING DISCLAIMER AND LIMITATION OF LIABLITY 
SHALL NOT APPLY TO RELIASOFT CORPORATION’S OBLIGATIONS UNDER ANY 
CLAIM OF INFRINGEMENT AS DESCRIBED IN SECTION 5.28 OF THIS AGREEMENT. 

5.23 Venue. Venue for any proceedings arising out of or relating to this Agreement shall be in 
Tucson, Pima County, Arizona. The parties disclaim the application of the United Nations 
Convention on Contracts for the International Sale of Goods. This Agreement is governed 
by the laws of the State of Arizona, USA, without reference to conflict to law principles. 
Each party to this Agreement submits to the exclusive jurisdiction of the state and federal 
courts in the State of Arizona for the purpose of resolving any disputes arising under or 
relating to this Agreement. Each party waives any jurisdictional, venue or inconvenient 
forum objections to such courts. 

5.24 Legal Expenses. If legal action is taken by either party to enforce this Agreement, all costs 
and expenses (including reasonable attorney fees) incurred by the prevailing party in 
exercising any of its rights or remedies or in enforcing any of the terms, conditions, or 
provisions of this Agreement will be paid by the other party. 

5.25 Force Majeure. ReliaSoft Corporation will not be responsible for delays or failures in its 
performance due, in whole or in part, to any cause beyond its reasonable control. 

5.26 Export Control. Regardless of any disclosure made by You to ReliaSoft Corporation of an 
ultimate destination of the Application, You will not export, either directly or indirectly any 
Application without first obtaining all licenses required, from the U.S. Department of 
Commerce or any other agency or department of the United States Government, and 
complying with the applicable laws. Neither the Application nor any direct product thereof 
may be exported, directly or indirectly, in violation of applicable export laws, or may be used 
for any purpose prohibited by these laws including, without limitation, nuclear, chemical or 
biological weapons proliferation. ReliaSoft Corporation will provide You with all reasonable 
information requested by You in connection to exporting the Application, including providing 
You with the U.S. Export Controls Classification Number (ECCN) for the Application. 

5.27 Waiver. The waiver by either party of any breach of this Agreement shall be in writing and 
shall not constitute a waiver of any other or subsequent breach. No waiver of any of the 
provisions of this Agreement will be deemed, or will constitute, a waiver of any other 
provision, whether or not similar, nor will any waiver constitute a continuing waiver. The 
failure by a party to enforce any provision of this Agreement will not be deemed a waiver of 
future enforcement of that or any other provision. 

5.28 Indemnification. You will indemnify and hold ReliaSoft Corporation harmless against any 
and all claims, damages, losses, costs or other expenses (including reasonable attorney 
fees) that arise directly or indirectly from your breach of this Agreement. ReliaSoft 
Corporation shall defend, indemnify and hold harmless, at its own expense, You and your 
assigns, successors, directors, officers and employees (each an “Indemnified Party”) 
against any and all claims incurred by or made against an Indemnified Party by a third party 
in connection with a claim, suit or action which is based on an allegation that the Application 
when used by You as authorized under this Agreement, misappropriates or infringes any 



third party patent, copyright, trade secret or other intellectual property right (each, a “Claim”)  
provided that ReliaSoft Corporation shall have received from the Indemnified Party:  (i) 
notice of such Claim as soon as possible after You receive notice of the Claim; given that a 
failure to provide notice shall only relieve ReliaSoft Corporation of its indemnity obligation to 
the extent ReliaSoft Corporation was prejudiced by such failure; (ii) the exclusive right to 
control and direct the investigation, defense or settlement of such claim; and (iii) all 
reasonable necessary cooperation by You. If your use of any of the Application is, or in 
ReliaSoft Corporation’s opinion is likely to be, enjoined due to a Claim, ReliaSoft 
Corporation may, at its sole discretion:  (a) modify the Application so that it becomes non-
infringing, provided such modifications result in software with substantially similar 
functionality and performance; (b) procure for You the right to continue using the Application 
under substantially the same terms and conditions as provided for hereunder; or (c) if (a) 
and (b) are commercially impracticable, terminate the Agreement and refund to You the 
license fee paid by You for the Application which is the subject of the Claim as reduced to 
reflect a three-year straight-line depreciation from the applicable license purchase date. The 
foregoing indemnification obligation of ReliaSoft Corporation shall not apply:  (1) if the 
Application is modified by any party other than ReliaSoft Corporation and such modification 
was not authorized in writing by ReliaSoft Corporation, but solely to the extent the alleged 
infringement is caused by such modification; or (2) to any release of the Application other 
than the most current release, provided that: (I) the most current release was either made 
available at no cost to You and (II) You had a commercially reasonable period of time (not 
to exceed 60 days) after availability of the current release to implement the current release 
so as to avoid the infringement claim. This section (Section 5.28) sets forth ReliaSoft 
Corporation’s sole liability and your sole and exclusive remedy with respect to any claim of 
infringement. 

5.29 Equitable Relief. You acknowledge and agree that, due to the unique nature of the 
Application, there can be no adequate remedy at law for any breach of your obligations 
under this Agreement, that any such breach may allow You or third parties to unfairly 
compete with ReliaSoft Corporation resulting in irreparable harm and therefore that, upon 
any such breach or threat thereof, ReliaSoft Corporation shall be entitled to injunctive and 
other appropriate equitable relief in addition to whatever remedies it may have at law. 

5.30 Entire Agreement; Amendments. This Agreement is the complete and exclusive 
statement of the agreement between the parties and supersedes all prior agreements and 
communications with respect to the subject matter, and there are no oral representations, 
understandings or agreements that are not fully expressed herein. Any terms appearing on 
any order or other form used by You which modify or conflict with the terms and conditions 
set forth herein are expressly rejected. Except for the purpose of negating implied 
warranties, no course of prior dealings between the parties and no usage of the trade shall 
be relevant to supplement or explain any term used in this Agreement. No ReliaSoft 
Corporation employee other than an officer of ReliaSoft Corporation (Vice President and 
above) shall have any actual or apparent authority to modify the terms of this Agreement in 
any way. All amendments shall be in writing and signed by the authorized representative of 
ReliaSoft Corporation. 



5.31 Severability.  If any one or more of the provisions of this Agreement shall for any reason be 
held to be invalid, illegal or unenforceable in any respect, any such provision shall be 
severable from this Agreement, in which event this Agreement shall be construed as if such 
provision had never been contained herein. 

5.32 Electronic Signatures.  ReliaSoft Corporation and You agree that this Agreement may be 
executed electronically and that electronic copies of this Agreement shall be binding upon 
the parties to the same extent as manually-executed copies. 
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